git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] Rename safe_strncpy() to strlcpy().

From
Junio C Hamano <junkio@cox.net>
Date
Jun 25, 2006, 05:29 UTC
Message-ID
<7vd5cxzttx.fsf@assigned-by-dhcp.cox.net>
In-Reply-To
<20060624140124.GA1323@ebar092.ebar.dtu.dk>
"Peter Eriksen" <s022018@student.dtu.dk> writes:
Show 6 quoted lines
> This cleans up the use of safe_strncpy() even more.  Since it has the
> same semantics as strlcpy() use this name instead.
> ---
>
> I've introduced a NO_STRLCPY variable in the Makefile.  What do
> you think about this?

No strong preference -- I can go with either name. But people with more BSD exposure than I am are probably used to see this function as strlcpy(), so if that is the case let's use this patch.

Thanks.
Previous: Peter Eriksen
Message 2 of 2 in “Rename safe_strncpy() to strlcpy().”
  1. Rename safe_strncpy() to strlcpy().Peter Eriksen, Jun 24, 2006
  2. Junio C HamanoJun 25, 2006

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.