From: Junio C Hamano Date: Sun, 25 Jun 2006 05:29:30 GMT Subject: Re: [PATCH] Rename safe_strncpy() to strlcpy(). Message-ID: <7vd5cxzttx.fsf@assigned-by-dhcp.cox.net> In-Reply-To: <20060624140124.GA1323@ebar092.ebar.dtu.dk> "Peter Eriksen" writes: > This cleans up the use of safe_strncpy() even more. Since it has the > same semantics as strlcpy() use this name instead. > --- > > I've introduced a NO_STRLCPY variable in the Makefile. What do > you think about this? No strong preference -- I can go with either name. But people with more BSD exposure than I am are probably used to see this function as strlcpy(), so if that is the case let's use this patch. Thanks.