git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] Move stripspace() and launch_editor() to strbuf.c

From
Junio C Hamano <gitster@pobox.com>
Date
Nov 11, 2007, 22:52 UTC
Message-ID
<7v6408bdjp.fsf@gitster.siamese.dyndns.org>
In-Reply-To
<Pine.LNX.4.64.0711112227420.4362@racer.site>
Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
> Maybe call_editor() instead of edit_buffer()?  Since we technically read 
> the file specified by "path" into the buffer "buffer", after having called 
> the editor.

Calling $EDITOR to edit the buffer is an implementation detail of letting the user edit the buffer. I think the function name should express what it does more than how it does it.

My suggested name does not convey the "letting the user" part, though.

Previous: Johannes Schindelin
Message 4 of 4 in “Move stripspace() and launch_editor() to strbuf.c”
  1. Move stripspace() and launch_editor() to strbuf.cJohannes Schindelin, Nov 11, 2007
  2. Junio C HamanoNov 11, 2007
  3. Johannes SchindelinNov 11, 2007
  4. Junio C HamanoNov 11, 2007

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.