git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/2] Rename submodule.<name>.rebase to submodule.<name>.update

From
Junio C Hamano <gitster@pobox.com>
Date
Jun 3, 2009, 02:33 UTC
Message-ID
<7v4ouydp0q.fsf@alter.siamese.dyndns.org>
In-Reply-To
<20090603001553.GB27149@dingo.bne.redhat.com>
Peter Hutterer <peter.hutterer@who-t.net> writes:
Show 18 quoted lines
> On Wed, Jun 03, 2009 at 12:59:11AM +0200, Johan Herland wrote:
> ...
>> diff --git a/Documentation/git-submodule.txt b/Documentation/git-submodule.txt
>> index acd16ac..cd8e861 100644
>> --- a/Documentation/git-submodule.txt
>> +++ b/Documentation/git-submodule.txt
>> @@ -116,7 +116,7 @@ update::
>>  	Update the registered submodules, i.e. clone missing submodules and
>>  	checkout the commit specified in the index of the containing repository.
>>  	This will make the submodules HEAD be detached unless '--rebase' is
>> -	specified or the key `submodule.$name.rebase` is set to `true`.
>> +	specified or the key `submodule.$name.update` is set to	`rebase`.
>>  +
>>  If the submodule is not yet initialized, and you just want to use the
>>  setting as stored in .gitmodules, you can automatically initialize the
> ...
> I noticed this patch still leaves the --rebase commandline flag. Shouldn't
> that be changed to --update=rebase for consistency?

If we were to add many more (I think --update=merge was mentioned, but do we have any other plausibly useful modes of operations?) options, it would make sense to support --update=rebase; my impression from the previous discussion was that rebase would make sense for more people than other modes would, so it also would make sense to keep --rebase as a shorthand, rather than forcing everybody to say --update=rebase for the sake of consistency.

You did not have to quote the whole patch to say what you wanted to say, by the way.

Previous: Peter HuttererNext: Johan Herland
Message 6 of 11 in “What's cooking in git.git (May 2009, #04; Sun, 31)”
  1. Junio C HamanoJun 1, 2009
  2. Brandon CaseyJun 1, 2009
  3. 0/2 "git submodule update" enhancements (Was: What's cooking in git.git (May 2009, #04; Sun, 31))Johan Herland, Jun 2, 2009
  4. 1/2 Rename submodule.<name>.rebase to submodule.<name>.updateJohan Herland, Jun 2, 2009
  5. Peter HuttererJun 3, 2009
  6. Junio C HamanoJun 3, 2009
  7. Johan HerlandJun 3, 2009
  8. Markus HeidelbergJun 3, 2009
  9. Johan HerlandJun 3, 2009
  10. 1/2 Rename submodule.<name>.rebase to submodule.<name>.updateJohan Herland, Jun 3, 2009
  11. 2/2 git-submodule: add support for --merge.Johan Herland, Jun 2, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.