git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/2] Rename submodule.<name>.rebase to submodule.<name>.update

From
Johan Herland <johan@herland.net>
Date
Jun 3, 2009, 06:46 UTC
Message-ID
<200906030846.35704.johan@herland.net>
In-Reply-To
<7v4ouydp0q.fsf@alter.siamese.dyndns.org>
On Wednesday 03 June 2009, Junio C Hamano wrote:
Show 11 quoted lines
> Peter Hutterer <peter.hutterer@who-t.net> writes:
> > I noticed this patch still leaves the --rebase commandline flag.
> > Shouldn't that be changed to --update=rebase for consistency?
>
> If we were to add many more (I think --update=merge was mentioned, but do
> we have any other plausibly useful modes of operations?) options, it
> would make sense to support --update=rebase; my impression from the
> previous discussion was that rebase would make sense for more people than
> other modes would, so it also would make sense to keep --rebase as a
> shorthand, rather than forcing everybody to say --update=rebase for the
> sake of consistency.

I agree. Even if we had a hundred alternatives, the most common should be available in shorthand form.

Also, I don't think it makes sense to introduce --update=foo until we have, say, 3-4 different alternatives. As long as --rebase and --merge are the only alternatives (no other alternatives have been suggested so far, AFAIK), I don't think we need to introduce --update=foo.

Have fun! :)
...Johan
-- 
Johan Herland, <johan@herland.net>
www.herland.net
Previous: Junio C HamanoNext: Markus Heidelberg
Message 7 of 11 in “What's cooking in git.git (May 2009, #04; Sun, 31)”
  1. Junio C HamanoJun 1, 2009
  2. Brandon CaseyJun 1, 2009
  3. 0/2 "git submodule update" enhancements (Was: What's cooking in git.git (May 2009, #04; Sun, 31))Johan Herland, Jun 2, 2009
  4. 1/2 Rename submodule.<name>.rebase to submodule.<name>.updateJohan Herland, Jun 2, 2009
  5. Peter HuttererJun 3, 2009
  6. Junio C HamanoJun 3, 2009
  7. Johan HerlandJun 3, 2009
  8. Markus HeidelbergJun 3, 2009
  9. Johan HerlandJun 3, 2009
  10. 1/2 Rename submodule.<name>.rebase to submodule.<name>.updateJohan Herland, Jun 3, 2009
  11. 2/2 git-submodule: add support for --merge.Johan Herland, Jun 2, 2009

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.