Re: [PATCH 2/2] Convert the users of for_each_string_list to for_each_string_list_item macro
Alex Riesen <raa.lkml@gmail.com> writes:
Show 10 quoted lines
> The rule for selecting the candidates for conversion is: if the callback
> function returns only 0 (the condition for for_each_string_list to exit
> early), than it can be safely converted to the macro.
>
> A notable exception are the callers in builtin/remote.c. If converted, the
> readability in the file will suffer greately. Besides, the code is not very
> performance critical (at the moment, at least): it does output formatting of
> the list of remotes.
>
> Signed-off-by: Alex Riesen <raa.lkml@gmail.com>
Both patches look very sane. Thanks.