[PATCH v3 01/11] merge-ort: add basic data structures for handling renames
- From
Elijah Newren via GitGitGadget <gitgitgadget@gmail.com>
- Date
- Dec 15, 2020, 18:27 UTC
- Message-ID
- <78621ca07887e39a41ad9cff7b8dd5dcc9b33fbc.1608056886.git.gitgitgadget@gmail.com>
- In-Reply-To
- <pull.812.v3.git.1608056886.gitgitgadget@gmail.com>
From: Elijah Newren <newren@gmail.com>
This will grow later, but we only need a few fields for basic rename handling.
Signed-off-by: Elijah Newren <newren@gmail.com> --- merge-ort.c | 24 ++++++++++++++++++++++++ 1 file changed, 24 insertions(+)
diff --git a/merge-ort.c b/merge-ort.c index 414e7b7eeac..1c1a7fa4bf1 100644 --- a/merge-ort.c +++ b/merge-ort.c @@ -46,6 +46,25 @@ enum merge_side { MERGE_SIDE2 = 2 }; +struct rename_info { + /* + * pairs: pairing of filenames from diffcore_rename() + * + * Index 1 and 2 correspond to sides 1 & 2 as used in + * conflict_info.stages. Index 0 unused. + */ + struct diff_queue_struct pairs[3]; + + /* + * needed_limit: value needed for inexact rename detection to run + * + * If the current rename limit wasn't high enough for inexact + * rename detection to run, this records the limit needed. Otherwise, + * this value remains 0. + */ + int needed_limit; +}; + struct merge_options_internal { /* * paths: primary data structure in all of merge ort. @@ -113,6 +132,11 @@ struct merge_options_internal { */ struct strmap output; + /* + * renames: various data relating to rename detection + */ + struct rename_info renames; + /* * current_dir_name: temporary var used in collect_merge_info_callback() *
-- gitgitgadget