Re: [PATCH] sequencer.c: unify error messages
- From
René Scharfe <l.s.r@web.de>
- Date
- Oct 13, 2017, 21:12 UTC
- Message-ID
- <58336f0d-366c-6636-1e94-22afbafdfe4c@web.de>
- In-Reply-To
- <20171013175157.13634-1-ralf.thielow@gmail.com>
Am 13.10.2017 um 19:51 schrieb Ralf Thielow:
> When ftruncate() in rearrange_squash() fails, we write > that we couldn't finish the operation on the todo file. > It is more accurate to write that we couldn't truncate > as we do in other calls of ftruncate().
Would it make sense to factor out rewriting the to-do file to avoid code duplication in the first place?
Show 17 quoted lines
> While at there, remove a full stop in another error message.
>
> Signed-off-by: Ralf Thielow <ralf.thielow@gmail.com>
> ---
> sequencer.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/sequencer.c b/sequencer.c
> index e258bb646..b0e6459a5 100644
> --- a/sequencer.c
> +++ b/sequencer.c
> @@ -2948,9 +2948,9 @@ int rearrange_squash(void)
> if (fd < 0)
> res = error_errno(_("could not open '%s'"), todo_file);
> else if (write(fd, buf.buf, buf.len) < 0)
> - res = error_errno(_("could not read '%s'."), todo_file);
> + res = error_errno(_("could not read '%s'"), todo_file);^^^^ That should read "write", right?
> else if (ftruncate(fd, buf.len) < 0)
> - res = error_errno(_("could not finish '%s'"),
> + res = error_errno(_("could not truncate '%s'"),
> todo_file);Hmm, why call ftruncate(2) instead of opening the file with O_TRUNC?
> close(fd); > strbuf_release(&buf); >