git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v3 5/7] convert: auto_crlf=false and no attributes set: same as binary

From
Torsten Bögershausen <tboegi@web.de>
Date
Feb 9, 2016, 14:34 UTC
Message-ID
<56B9F90E.2030304@web.de>
In-Reply-To
<xmqqzivb83d1.fsf@gitster.mtv.corp.google.com>
On 02/08/2016 07:27 PM, Junio C Hamano wrote:
Show 15 quoted lines
> tboegi@web.de writes:
>
>> From: Torsten Bögershausen <tboegi@web.de>
>>
>> When core.autocrlf is set to false, and no attributes are set, the file
>> is treated as binary.
> This, and also on the title, I know by "binary" you mean "no
> conversion is attempted", and it is the word used in the code around
> there, but it still makes my heart skip a beat every time I read
> this sentence--it is not like we do not treat the contents as text
> after all.
>
> In any case, I take the above sentence the statement of the fact,
> describing how the world currently is, not declaring a new world
> order.

The word binary is indeed not ideal here: no eol conversion is done. (And the commit message could use "-text")

Show 15 quoted lines
>> Simplify the logic and remove duplicated code when dealing with
>> (crlf_action == CRLF_GUESS && auto_crlf == AUTO_CRLF_FALSE) by
>> setting crlf_action=CRLF_BINARY already in convert_attrs().
> I looked at all the places where CRLF_BINARY is checked.  The ones
> that are in this patch are clearly where "Is it BINARY?" and "Is
> AUTO_CRLF_FALSE and CRLF_GUESS both true?" mean the same thing, so
> this is a correct simplification to these places.
>
> It is not easy to see what the effect of this change to the other
> places that use CRLF_BINARY, though.
>
>  * output_eol() used to return EOL_UNSET when auto_crlf is not in
>    effect and CRLF_GUESS is.  The function will see CRLF_BINARY with
>    this patch in such a case, and returns EOL_UNSET.  So there is no
>    change to the function and its callers.
OK
Show 6 quoted lines
>  * convert_attrs() has "If BINARY don't do anything and return".
>    Will the patch change behaviour for the "not-autocrlf,
>    CRLF_GUESS" case in this codepath?  I think ca->crlf_action used
>    to be left as CRLF_GUESS here before the patch, and now by the
>    time the control flow reaches here it is already CRLF_BINARY.
>    Would it affect the callers, and if so how?
Not sure if I fully understand the question:

The old CRLF_GUESS could mean (a) core.autocrlf=true, (b) core.autocrlf=input or (c) core.autocrlf=false. The callers had to look at the core.autocrlf them self. This patch removes (c), the next (or over next) (a) and (b)

    if (ca->crlf_action == CRLF_GUESS && auto_crlf == AUTO_CRLF_FALSE)
        ca->crlf_action = CRLF_BINARY;
}
The next patch 6/7 removes "GUESS" completely.
Show 8 quoted lines
>  * get_convert_attr_ascii() would change the behaviour, right?  It
>    runs convert_attrs(), and with this change a path without
>    attribute when autocrlf is not in effect would get BINARY and
>    would show "-text", while the code before this change would give
>    an empty string.  Am I misreading the code, or is the change
>    intended?
>
> Thanks.
(That happened in my first (not published) version,
today we have this:)
struct conv_attrs {
    struct convert_driver *drv;
    enum crlf_action attr_action; /* What attr says */
    enum crlf_action crlf_action; /* When no attr is set, use core.autocrlf */
    int ident;
};

The idea is (after this and the next commit 6/7) is that once we had run convert_attrs() there is a clear picture what should be done with the eols, and it is stored in crlf_action.

No further check with core.autocrlf in any calling party should be needed.

In a future series it should be possible to set *text=auto *eol=clrf to behave exactly as if core.autocrlf=true. But that is a change in behavior, and needs a separate series. This series should not change the behavior, so a critical review is appreciated.

Does this answers the questions ? Is a local amend possible ?

Previous: Junio C HamanoNext: Junio C Hamano
Message 31 of 47 in “t0027: Add tests for get_stream_filter()”
  1. t0027: Add tests for get_stream_filter()tboegi@web.de, Jan 24, 2016
  2. Junio C HamanoJan 27, 2016
  3. Torsten BögershausenJan 27, 2016
  4. 1/6 t0027: Add tests for get_stream_filter()tboegi@web.de, Jan 27, 2016
  5. 1/6 t0027: Add tests for get_stream_filter()tboegi@web.de, Feb 2, 2016
  6. Junio C HamanoFeb 2, 2016
  7. 2/6 convert.c: Remove path when not neededtboegi@web.de, Feb 2, 2016
  8. Junio C HamanoFeb 2, 2016
  9. 3/6 convert.c: Remove input_crlf_action()tboegi@web.de, Feb 2, 2016
  10. Junio C HamanoFeb 2, 2016
  11. 4/6 convert.c: Use text_eol_is_crlf()tboegi@web.de, Feb 2, 2016
  12. 5/6 convert: auto_crlf=false and no attributes set: same as binarytboegi@web.de, Feb 2, 2016
  13. 6/6 convert.c: Refactor crlf_actiontboegi@web.de, Feb 2, 2016
  14. 1/7 t0027: Add tests for get_stream_filter()tboegi@web.de, Feb 4, 2016
  15. Junio C HamanoFeb 4, 2016
  16. 2/7 convert.c: remove unused parameter 'path'tboegi@web.de, Feb 4, 2016
  17. 3/7 convert.c: Remove input_crlf_action()tboegi@web.de, Feb 4, 2016
  18. 4/7 convert.c: Use text_eol_is_crlf()tboegi@web.de, Feb 4, 2016
  19. Junio C HamanoFeb 4, 2016
  20. 5/7 convert: auto_crlf=false and no attributes set: same as binarytboegi@web.de, Feb 4, 2016
  21. 6/7 convert.c: Refactor crlf_actiontboegi@web.de, Feb 4, 2016
  22. 7/7 convert.c: simplify text_stattboegi@web.de, Feb 4, 2016
  23. Junio C HamanoFeb 4, 2016
  24. 1/7 t0027: Add tests for get_stream_filter()tboegi@web.de, Feb 5, 2016
  25. Junio C HamanoFeb 8, 2016
  26. 2/7 convert.c: remove unused parameter 'path'tboegi@web.de, Feb 5, 2016
  27. 3/7 convert.c: Remove input_crlf_action()tboegi@web.de, Feb 5, 2016
  28. 4/7 convert.c: use text_eol_is_crlf()tboegi@web.de, Feb 5, 2016
  29. 5/7 convert: auto_crlf=false and no attributes set: same as binarytboegi@web.de, Feb 5, 2016
  30. Junio C HamanoFeb 8, 2016
  31. Torsten BögershausenFeb 9, 2016
  32. Junio C HamanoFeb 9, 2016
  33. 6/7 convert.c: refactor crlf_actiontboegi@web.de, Feb 5, 2016
  34. 7/7 convert.c: simplify text_stattboegi@web.de, Feb 5, 2016
  35. 1/6 t0027: add tests for get_stream_filter()tboegi@web.de, Feb 10, 2016
  36. 2/6 convert.c: remove unused parameter 'path'tboegi@web.de, Feb 10, 2016
  37. 3/6 convert.c: remove input_crlf_action()tboegi@web.de, Feb 10, 2016
  38. 4/6 convert.c: use text_eol_is_crlf()tboegi@web.de, Feb 10, 2016
  39. 5/6 convert.c: refactor crlf_actiontboegi@web.de, Feb 10, 2016
  40. 6/6 convert.c: simplify text_stattboegi@web.de, Feb 10, 2016
  41. 1/1 convert.c: correct attr_actiontboegi@web.de, Feb 22, 2016
  42. Eric SunshineFeb 22, 2016
  43. Junio C HamanoFeb 22, 2016
  44. Junio C HamanoFeb 22, 2016
  45. Torsten BögershausenFeb 23, 2016
  46. 1/1 convert.c: correct attr_actiontboegi@web.de, Feb 23, 2016
  47. Junio C HamanoFeb 23, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.