Re: [RFH] renaming strcmp/strncmp-icase
Am 08.09.2014 um 20:52 schrieb Junio C Hamano:
Show 18 quoted lines
> There are these two functions in dir.c that has only a handful of
> callers outside:
>
> int strcmp_icase(const char *a, const char *b);
> int strncmp_icase(const char *a, const char *b, size_t count);
>
> How many of you would think these are about comparing two strings in
> a case-insensitive way?
>
> If you raised your hand (like I did), you were wrong. These do
> comparison case-insensitively only on a case-insensitive filesystem,
> and hence calling it makes sense only for pathnames you grabbed out
> of the filesystem via readdir() (or the user gave us, intending to
> name paths).
>
> To avoid confusion, I think they should be renamed to stress the
> fact that these are about comparing *PATHS*. As I always say, I am
> bad at naming things and good suggestions are appreciated.
> pathnamecmp()/pathnamencmp() perhaps?
"namen" looks strange to me. How about pathcmp/pathncmp?
René