Re: [PATCH v2 02/21] path.c: rename vsnpath() to git_vsnpath()
- From
Ramsay Jones <ramsay@ramsay1.demon.co.uk>
- Date
- Dec 16, 2013, 22:59 UTC
- Message-ID
- <52AF85CB.90107@ramsay1.demon.co.uk>
- In-Reply-To
- <20131216171147.GA28604@google.com>
On 16/12/13 17:11, Jonathan Nieder wrote:
Show 17 quoted lines
> Duy Nguyen wrote:
>>>> Ramsay Jones wrote:
>
>>>>> :-D I renamed this _from_ git_vsnpath() in commit 5b3b8fa2 ("path.c: Remove the
>>>>> 'git_' prefix from a file scope function", 04-09-2012), because ... well it's a
>>>>> file scope function! (i.e. the git_ prefix implies greater than file scope).
>>>>> I'm not very good at naming things, so ...
> [...]
>> OK I go with this. I think it makes sense
>>
>> vsnpath -> do_git_path
>
> I think this renaming would be still losing clarity --- it loses the
> information that this is the vsnprintf-like variant of git_path.
>
> Do we actually have a convention that functions with git_ prefix
> should be global?Hmm, probably not no. However, any symbol that starts with git_ positively screams global symbol to me. Maybe, I just need to close my ears. ;-)
I didn't intend to provoke so much discussion. I was simply pointing out that this symbol had already been renamed, in the exact opposite direction, once before. Please just ignore me.
ATB, Ramsay Jones