[PATCH] merge-recursive: use fspathcmp() in path_hashmap_cmp()
- From
René Scharfe <l.s.r@web.de>
- Date
- Aug 28, 2021, 21:30 UTC
- Message-ID
- <512abaef-d71c-9308-6a62-f37b4de69e60@web.de>
Call fspathcmp() instead of open-coding it. This shortens the code and makes it less repetitive.
Signed-off-by: René Scharfe <l.s.r@web.de> --- merge-recursive.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/merge-recursive.c b/merge-recursive.c index 3355d50e8a..840599fd53 100644 --- a/merge-recursive.c +++ b/merge-recursive.c @@ -55,10 +55,7 @@ static int path_hashmap_cmp(const void *cmp_data, a = container_of(eptr, const struct path_hashmap_entry, e); b = container_of(entry_or_key, const struct path_hashmap_entry, e); - if (ignore_case) - return strcasecmp(a->path, key ? key : b->path); - else - return strcmp(a->path, key ? key : b->path); + return fspathcmp(a->path, key ? key : b->path); } /* -- 2.33.0