Re: [PATCH] merge-recursive: use fspathcmp() in path_hashmap_cmp()
Am 29.08.21 um 22:21 schrieb Taylor Blau:
Show 47 quoted lines
> Hi René,
>
> On Sat, Aug 28, 2021 at 11:30:49PM +0200, René Scharfe wrote:
>> Call fspathcmp() instead of open-coding it. This shortens the code and
>> makes it less repetitive.
>>
>> Signed-off-by: René Scharfe <l.s.r@web.de>
>> ---
>> merge-recursive.c | 5 +----
>> 1 file changed, 1 insertion(+), 4 deletions(-)
>>
>> diff --git a/merge-recursive.c b/merge-recursive.c
>> index 3355d50e8a..840599fd53 100644
>> --- a/merge-recursive.c
>> +++ b/merge-recursive.c
>> @@ -55,10 +55,7 @@ static int path_hashmap_cmp(const void *cmp_data,
>> a = container_of(eptr, const struct path_hashmap_entry, e);
>> b = container_of(entry_or_key, const struct path_hashmap_entry, e);
>>
>> - if (ignore_case)
>> - return strcasecmp(a->path, key ? key : b->path);
>> - else
>> - return strcmp(a->path, key ? key : b->path);
>> + return fspathcmp(a->path, key ? key : b->path);
>> }
>
> Looks obviously right to me. I found another spot in
> t/helper/test-hashmap.c:test_entry_cmp() that could be cleaned up in the
> same way. But this looks fine with or without the following diff:
>
> diff --git a/t/helper/test-hashmap.c b/t/helper/test-hashmap.c
> index 36ff07bd4b..ab34bdfecd 100644
> --- a/t/helper/test-hashmap.c
> +++ b/t/helper/test-hashmap.c
> @@ -28,10 +28,7 @@ static int test_entry_cmp(const void *cmp_data,
> e1 = container_of(eptr, const struct test_entry, ent);
> e2 = container_of(entry_or_key, const struct test_entry, ent);
>
> - if (ignore_case)
> - return strcasecmp(e1->key, key ? key : e2->key);
> - else
> - return strcmp(e1->key, key ? key : e2->key);
> + return fspathcmp(e1->key, key ? key : e2->key);
> }
>
> static struct test_entry *alloc_test_entry(unsigned int hash,
>
That's a local variable named "ignore_case", not the one declared in environment.c that fspathcmp() uses, so this would change the behavior. The helper code does not include cache.h, so this is not even a case of variable shadowing, just two different variables for similar purposes in different places having the same name.
René