Re: [PATCH 1/4] mergetool--lib: Simplify command expressions
- From
Johannes Sixt <j6t@kdbg.org>
- Date
- Jan 27, 2013, 22:08 UTC
- Message-ID
- <5105A56E.4010002@kdbg.org>
- In-Reply-To
- <1359321886-80523-2-git-send-email-davvid@gmail.com>
Am 27.01.2013 22:24, schrieb David Aguilar:
> Use $(command "$arg") instead of "$(command "$arg")" as the latter is > harder to read.
If at all, you should restrict yourself to simplify only variable assignments. Because this case:
> - if test -z "$(get_merge_tool_cmd "$merge_tool")" && > + if test -z $(get_merge_tool_cmd "$merge_tool") &&
cannot work as intended: If the output of $() is empty, then without the outer quotes this becomes
test -z
without an operand for -z, which is a syntax error (of the test command).
-- Hannes