Re: [PATCH 2/3] Convert hash functions to char instead of struct object
- From
Johannes Sixt <j.sixt@viscovery.net>
- Date
- May 19, 2009, 06:23 UTC
- Message-ID
- <4A12507A.3050307@viscovery.net>
- In-Reply-To
- <1242707644-29893-2-git-send-email-dpmcgee@gmail.com>
Dan McGee schrieb:
> -static unsigned int hash_obj(struct object *obj, unsigned int n) > +static unsigned int hash_chars(const unsigned char *c, unsigned int n)
hash_chars suggests that this function hashes arbitrary character sequences, but it doesn't do that. Wouldn't hash_object_id be a better name? (And the parameter would then obviously be named sha1 or id.)
-- Hannes