[PATCH v6 5/6] xdiff/xdl_cleanup_records: make setting action easier to follow
- From
Ezekiel Newren via GitGitGadget <gitgitgadget@gmail.com>
- Date
- Apr 29, 2026, 22:08 UTC
- Message-ID
- <45ad2ae62de99de598088fd041559ff3a23ef82c.1777500495.git.gitgitgadget@gmail.com>
- In-Reply-To
- <pull.2156.v6.git.git.1777500495.gitgitgadget@gmail.com>
From: Ezekiel Newren <ezekielnewren@gmail.com>
Rewrite nested ternaries with a clear if/else ladder for action1/action2 to improve readability while preserving behavior.
Signed-off-by: Ezekiel Newren <ezekielnewren@gmail.com> --- xdiff/xprepare.c | 14 ++++++++++++-- 1 file changed, 12 insertions(+), 2 deletions(-)
diff --git a/xdiff/xprepare.c b/xdiff/xprepare.c index 7141dbc058..ddd0577676 100644 --- a/xdiff/xprepare.c +++ b/xdiff/xprepare.c @@ -302,7 +302,12 @@ static int xdl_cleanup_records(xdlclassifier_t *cf, xdfile_t *xdf1, xdfile_t *xd size_t mph1 = xdf1->recs[i].minimal_perfect_hash; rcrec = cf->rcrecs[mph1]; nm = rcrec ? rcrec->len2 : 0; - action1[i] = (nm == 0) ? DISCARD: nm >= mlim1 ? INVESTIGATE: KEEP; + if (nm == 0) + action1[i] = DISCARD; + else if (nm < mlim1) + action1[i] = KEEP; + else /* nm >= mlim1 */ + action1[i] = INVESTIGATE; } if (need_min) { @@ -317,7 +322,12 @@ static int xdl_cleanup_records(xdlclassifier_t *cf, xdfile_t *xdf1, xdfile_t *xd size_t mph2 = xdf2->recs[i].minimal_perfect_hash; rcrec = cf->rcrecs[mph2]; nm = rcrec ? rcrec->len1 : 0; - action2[i] = (nm == 0) ? DISCARD: nm >= mlim2 ? INVESTIGATE: KEEP; + if (nm == 0) + action2[i] = DISCARD; + else if (nm < mlim2) + action2[i] = KEEP; + else /* nm >= mlim2 */ + action2[i] = INVESTIGATE; } /*
-- gitgitgadget