jk/loose-object-cache
- From
René Scharfe <l.s.r@web.de>
- Date
- Jan 6, 2019, 16:39 UTC
- Message-ID
- <3512c798-aa42-6fba-ee82-d33a8985be91@web.de>
- In-Reply-To
- <xmqqh8explya.fsf@gitster-ct.c.googlers.com>
Am 28.12.2018 um 19:04 schrieb Junio C Hamano:
Show 19 quoted lines
> * jk/loose-object-cache (2018-11-24) 10 commits > (merged to 'next' on 2018-12-28 at 5a5faf384e) > + odb_load_loose_cache: fix strbuf leak > + fetch-pack: drop custom loose object cache > + sha1-file: use loose object cache for quick existence check > + object-store: provide helpers for loose_objects_cache > + sha1-file: use an object_directory for the main object dir > + handle alternates paths the same as the main object dir > + sha1_file_name(): overwrite buffer instead of appending > + rename "alternate_object_database" to "object_directory" > + submodule--helper: prefer strip_suffix() to ends_with() > + fsck: do not reuse child_process structs > > Originally merged to 'next' on 2018-11-24 > > Code clean-up with optimization for the codepath that checks > (non-)existence of loose objects. > > Will merge to 'master'.
So this has hit master in the meantime. We discussed a sort performance fix in [1]; I'll reply with a short series containing a cleaned-up and rebased version as a follow-up.
object-store: factor out odb_loose_cache() object-store: factor out odb_clear_loose_cache() object-store: use one oid_array per subdirectory for loose cache
object-store.h | 12 +++++++++++- object.c | 2 +- packfile.c | 7 ++----- sha1-file.c | 24 ++++++++++++++++++++---- sha1-name.c | 10 +++++----- 5 files changed, 39 insertions(+), 16 deletions(-)
[1] https://public-inbox.org/git/221cb2e4-a024-e301-2b3f-e37dcd93795e@web.de/