Re: [PATCH v3 1/4] t: move reftable/readwrite_test.c to the unit testing framework
- From
Josh Steadmon <steadmon@google.com>
- Date
- Aug 13, 2024, 22:33 UTC
- Message-ID
- <2rxxfpzijfmvo65xournnmx4oawzqlhgipje4cxzxvo5aqzt6u@xppoikj262cp>
- In-Reply-To
- <20240813144440.4602-2-chandrapratap3519@gmail.com>
On 2024.08.13 20:04, Chandra Pratap wrote:
Show 11 quoted lines
> reftable/readwrite_test.c exercises the functions defined in
> reftable/reader.{c,h} and reftable/writer.{c,h}. Migrate
> reftable/readwrite_test.c to the unit testing framework. Migration
> involves refactoring the tests to use the unit testing framework
> instead of reftable's test framework and renaming the tests to
> align with unit-tests' naming conventions.
>
> Since some tests in reftable/readwrite_test.c use the functions
> set_test_hash(), noop_flush() and strbuf_add_void() defined in
> reftable/test_framework.{c,h} but these files are not #included
> in the ported unit test, copy these functions in the new test file.I'm assuming that eventually, reftable/test_framework (and all the rest of reftable/libreftable_test.a) will be removed after all the tests are converted to the unit test framework, is that correct? Will other tests need these test_framework functions? If so, I'd rather not end up with duplicates in each test file, even if these are small functions. Is there a reason why we can't link the reftable/test_framework object (or the whole reftable/libreftable_test.a library)?