git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 3/3] xdiff: introduce XDL_ALLOC_GROW()

From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
Date
Jun 30, 2022, 13:25 UTC
Message-ID
<220630.86zghuclzq.gmgdl@evledraar.gmail.com>
In-Reply-To
<0a1650bf-a7f5-0cc5-e6c9-0e02d1f542bf@gmail.com>
On Thu, Jun 30 2022, Phillip Wood wrote:
Show 20 quoted lines
> On 30/06/2022 13:03, Phillip Wood wrote:
>> On 30/06/2022 11:54, Ævar Arnfjörð Bjarmason wrote:
>>>
>>> On Wed, Jun 29 2022, Phillip Wood via GitGitGadget wrote:
>>>
>>>> From: Phillip Wood <phillip.wood@dunelm.org.uk>
>>>>
>>>> Add a helper to grow an array. This is analogous to ALLOC_GROW() in
>>>> the rest of the codebase but returns −1 on allocation failure to
>>>> accommodate other users of libxdiff such as libgit2.
>>>
>>> Urm, does it? I just skimmed this, so maybe I missed something, but I
>>> don't see where you changed the definition of xdl_malloc(),
>>> xdl_realloc() etc.
>
> Oh I think I might have misunderstood your question. For git.git it
> will still die() but for other users that arrange for xdl_realloc() to
> return NULL on failure it will return -1. The same applies to the
> comments in the previous two patches about XDL_[CM]ALLOC_ARRAY()
> returning NULL on allocation failure.

Yes, I meant that the "but returns −1 on allocation failure to accommodate other users of libxdiff such as libgit2" is really more of a:

	...but *allows for* dropping in another xmalloc(), xrealloc()
	etc. implementation that doesn't die on failure.
So I think the rest of my upthread question still stands, i.e.:
	"So if that's the plan why would we need an XDL_ALLOC_ARRAY(),
	can't you just check that it [I mean ALLOC_ARRAY()] returns
	non-NULL?"

I.e. if the plan is to replace the underlying x*() functions with non-fatal variants can't you use ALLOC_ARRAY() instead? I haven't tried that, but I don't see a reason we couldn't do that in principle...

Anyway, I'm all for the end goal here, but the way to get there seems to be a bit of an exercise in running with scissors the more I think about it.

I.e. the reason we're using these x*alloc() wrappers at all is because we're lazy and want to write stuff like:

	struct stuff *foo = xmalloc(...);
	foo->bar = "baz";

Which the compiler is helpfully not yelling at us about, as opposed to doing the same with "malloc()", where it would spot the potential null pointer dereference.

(I'm using "compiler" here to be inclusive of extended gcc/clang options to detect this sort of thing, & other similar analyzers).

But re "scissors": if we're doing to be maintaining the xdiff code in-tree to be defined as our usual x*alloc() functions we're going to be carrying code that can't have test or analysis coverage.

Which I think brings me back to my suggestion of whether we can't just have non-fatal versions of these helper macros, define our own currently fatal versions in terms of those, and use the non-fatal versions in the xdiff/ code.

Previous: Phillip WoodNext: Phillip Wood
Message 10 of 52 in “xdiff: introduce memory allocation macros”
  1. 0/3 xdiff: introduce memory allocation macrosPhillip Wood via GitGitGadget, Jun 29, 2022
  2. 1/3 xdiff: introduce XDL_ALLOC_ARRAY()Phillip Wood via GitGitGadget, Jun 29, 2022
  3. 2/3 xdiff: introduce XDL_CALLOC_ARRAY()Phillip Wood via GitGitGadget, Jun 29, 2022
  4. Junio C HamanoJun 30, 2022
  5. Phillip WoodJul 6, 2022
  6. 3/3 xdiff: introduce XDL_ALLOC_GROW()Phillip Wood via GitGitGadget, Jun 29, 2022
  7. Ævar Arnfjörð BjarmasonJun 30, 2022
  8. Phillip WoodJun 30, 2022
  9. Phillip WoodJun 30, 2022
  10. Ævar Arnfjörð BjarmasonJun 30, 2022
  11. Phillip WoodJul 6, 2022
  12. Ævar Arnfjörð BjarmasonJul 7, 2022
  13. Phillip WoodJul 8, 2022
  14. 0/7 xdiff: use standard alloc macros, share them via git-shared-util.hÆvar Arnfjörð Bjarmason, Jul 8, 2022
  15. 1/7 xdiff: simplify freeing patterns around xdl_free_env()Ævar Arnfjörð Bjarmason, Jul 8, 2022
  16. 2/7 git-shared-util.h: move "shared" allocation utilities hereÆvar Arnfjörð Bjarmason, Jul 8, 2022
  17. 3/7 git-shared-util.h: add G*() versions of *ALLOC_*()Ævar Arnfjörð Bjarmason, Jul 8, 2022
  18. Phillip WoodJul 11, 2022
  19. 5/7 xdiff: use GALLOC_GROW(), not XDL_ALLOC_GROW()Ævar Arnfjörð Bjarmason, Jul 8, 2022
  20. Phillip WoodJul 11, 2022
  21. Ævar Arnfjörð BjarmasonJul 11, 2022
  22. Phillip WoodJul 13, 2022
  23. Ævar Arnfjörð BjarmasonJul 13, 2022
  24. Phillip WoodJul 13, 2022
  25. 4/7 xdiff: use G[C]ALLOC_ARRAY(), not XDL_CALLOC_ARRAY()Ævar Arnfjörð Bjarmason, Jul 8, 2022
  26. Phillip WoodJul 11, 2022
  27. 6/7 xdiff: remove xdl_malloc() wrapper, use malloc(), not xmalloc()Ævar Arnfjörð Bjarmason, Jul 8, 2022
  28. Phillip WoodJul 8, 2022
  29. Ævar Arnfjörð BjarmasonJul 8, 2022
  30. Jeff KingJul 8, 2022
  31. Ævar Arnfjörð BjarmasonJul 8, 2022
  32. Jeff KingJul 11, 2022
  33. 7/7 xdiff: remove xdl_free(), use free() insteadÆvar Arnfjörð Bjarmason, Jul 8, 2022
  34. Phillip WoodJul 8, 2022
  35. Ævar Arnfjörð BjarmasonJul 8, 2022
  36. Phillip WoodJul 11, 2022
  37. Phillip WoodJul 11, 2022
  38. Ævar Arnfjörð BjarmasonJul 11, 2022
  39. Phillip WoodJul 13, 2022
  40. Ævar Arnfjörð BjarmasonJul 13, 2022
  41. Junio C HamanoJun 30, 2022
  42. Phillip WoodJul 6, 2022
  43. Ævar Arnfjörð BjarmasonJun 30, 2022
  44. 0/4 xdiff: introduce memory allocation macrosPhillip Wood via GitGitGadget, Jul 8, 2022
  45. 2/4 xdiff: introduce xdl_callocPhillip Wood via GitGitGadget, Jul 8, 2022
  46. 1/4 xdiff: introduce XDL_ALLOC_ARRAY()Phillip Wood via GitGitGadget, Jul 8, 2022
  47. 4/4 xdiff: introduce XDL_ALLOC_GROW()Phillip Wood via GitGitGadget, Jul 8, 2022
  48. Ævar Arnfjörð BjarmasonJul 8, 2022
  49. Phillip WoodJul 11, 2022
  50. Jeff KingJul 12, 2022
  51. Phillip WoodJul 13, 2022
  52. 3/4 xdiff: introduce XDL_CALLOC_ARRAY()Phillip Wood via GitGitGadget, Jul 8, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.