Re: [PATCH v2 4/4] packfile: recover when a multi-pack-index names a removed pack
- From
Jeff King <peff@peff.net>
- Date
- Aug 29, 2026, 11:34 UTC
- Message-ID
- <20260829113441.GD40814@coredump.intra.peff.net>
- In-Reply-To
- <CABPp-BFhPONjNuVZQfgwKuYdgbm5Fjjttz5q5wSYX6j1Zdwdww@mail.gmail.com>
On Fri, Aug 28, 2026 at 12:29:49AM -0700, Elijah Newren wrote:
Show 7 quoted lines
> > We've changed the return value semantics without changing the signature > > (or name). So we need to make sure we adjust all callers, as here. > > That's _probably_ OK in practice for such a specialized function. But we > > could also rename it if we wanted to be paranoid (especially about > > new callers added on parallel branches). > > Any suggestions for alternate names? fill_midx_entry_result? midx_fill_entry?
I did not have a good suggestion, but midx_fill_entry (which it looks like your new series uses) seems reasonable. It is probably the better name anyway, as it fits the subsystem_verb_the_thing() ordering.
I'll take a look at the new series and comment further there (if needed; my fingers are crossed for perfection).
-Peff