Re: [PATCH 0/12] git_config_string() considered harmful
- From
Jeff King <peff@peff.net>
- Date
- Apr 7, 2024, 01:08 UTC
- Message-ID
- <20240407010858.GA1076556@coredump.intra.peff.net>
- In-Reply-To
- <20240407005656.GA436890@coredump.intra.peff.net>
On Sat, Apr 06, 2024 at 08:56:56PM -0400, Jeff King wrote:
Show 13 quoted lines
> Subject: Re: [PATCH 0/12] git_config_string() considered harmful > [...] > [01/11]: config: make sequencer.c's git_config_string_dup() public > [02/11]: config: add git_config_pathname_dup() > [03/11]: config: prefer git_config_string_dup() for temp variables > [04/11]: config: use git_config_string_dup() for open-coded equivalents > [05/11]: config: use git_config_string_dup() to fix leaky open coding > [06/11]: config: use git_config_string() in easy cases > [07/11]: config: use git_config_pathname_dup() in easy cases > [08/11]: http: use git_config_string_dup() > [09/11]: merge: use git_config_string_dup() for pull strategies > [10/11]: userdiff: use git_config_string_dup() when we can > [11/11]: blame: use "dup" string_list for ignore-revs files
The cover letter subject is wrong, of course. :) I wrote it manually and ended up squashing two of the patches at the last minute.
-Peff