git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] Use ^=1 to toggle between 0 and 1

From
Jeff King <peff@peff.net>
Date
Dec 13, 2023, 08:01 UTC
Message-ID
<20231213080143.GA1684525@coredump.intra.peff.net>
In-Reply-To
<8bea38fe-38a3-412a-b189-541a6596d623@web.de>
On Tue, Dec 12, 2023 at 11:30:03PM +0100, René Scharfe wrote:
Show 21 quoted lines
> Am 12.12.23 um 21:09 schrieb Jeff King:
> > On Tue, Dec 12, 2023 at 05:17:47PM +0000, AtariDreams via GitGitGadget wrote:
> >
> >> diff --git a/diff.c b/diff.c
> >> index 2c602df10a3..91842b54753 100644
> >> --- a/diff.c
> >> +++ b/diff.c
> >> @@ -1191,7 +1191,7 @@ static void mark_color_as_moved(struct diff_options *o,
> >>  							    &pmb_nr);
> >>
> >>  			if (contiguous && pmb_nr && moved_symbol == l->s)
> >> -				flipped_block = (flipped_block + 1) % 2;
> >> +				flipped_block ^= 1;
> >>  			else
> >>  				flipped_block = 0;
> >
> > This one I do not see any problem with changing, though I think it is a
> > matter of opinion on which is more readable (I actually tend to think of
> > "x = 0 - x" as idiomatic for flipping).
> 
> Did you mean "x = 1 - x"?
Oops, yes, of course. I'm not sure how I managed to fumble that.
> I don't particular like this; it repeats x and seems error-prone. ;-)
Yes. :)

Without digging into the code, I had just assumed that flipped_block was used as an array index. But it really is a boolean, so I actually think "flipped_block = !flipped_block" would probably be the most clear (but IMHO not really worth the churn).

> Can we salvage something from this bikeshedding exercise?  I wonder if
> it's time to use the C99 type _Bool in our code.  It would allow
> documenting that only two possible values exist in cases like the one
> above.  That would be even more useful for function returns, I assume.

Hmm, possibly. I guess that might have helped my confusion, and I do think returning bool for function returns would help make their meaning more clear (it would help distinguish them from the usual "0 for success" return values).

I don't even know that we'd need much of a weather-balloon patch. I think it would be valid to do:

  #ifndef bool
  #define bool int

to handle pre-C99 compilers (if there even are any these days). Of course we probably need some conditional magic to try to "#include <stdbool.h>" for the actual C99. I guess we could assume C99 by default and then add NO_STDBOOL as an escape hatch if anybody complains.

-Peff
Previous: René ScharfeNext: Junio C Hamano
Message 5 of 26 in “Use ^=1 to toggle between 0 and 1”
  1. Use ^=1 to toggle between 0 and 1AtariDreams via GitGitGadget, Dec 12, 2023
  2. Dragan SimicDec 12, 2023
  3. Jeff KingDec 12, 2023
  4. René ScharfeDec 12, 2023
  5. Jeff KingDec 13, 2023
  6. Junio C HamanoDec 13, 2023
  7. René ScharfeDec 14, 2023
  8. Jeff KingDec 14, 2023
  9. Phillip WoodDec 15, 2023
  10. Junio C HamanoDec 15, 2023
  11. René ScharfeDec 16, 2023
  12. Phillip WoodDec 18, 2023
  13. git-compat-util: convert skip_{prefix,suffix}{,_mem} to boolRené Scharfe, Dec 16, 2023
  14. Phillip WoodDec 18, 2023
  15. Junio C HamanoDec 18, 2023
  16. René ScharfeDec 19, 2023
  17. Jeff KingDec 21, 2023
  18. Jeff KingDec 21, 2023
  19. phillip.wood123@gmail.comDec 21, 2023
  20. Use ^=1 to toggle between 0 and 1AreaZR via GitGitGadget, Dec 18, 2024
  21. git: use ^=1 to toggle between 0 and 1AreaZR via GitGitGadget, Dec 18, 2024
  22. git: use ^=1 to toggle between 0 and 1AreaZR via GitGitGadget, Dec 18, 2024
  23. git: use ^=1 to toggle between 0 and 1AreaZR via GitGitGadget, Dec 18, 2024
  24. git: use logical-not operator to toggle between 0 and 1AreaZR via GitGitGadget, Dec 18, 2024
  25. Junio C HamanoDec 19, 2024
  26. Junio C HamanoDec 18, 2024

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.