git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v3 0/6] submodule: remove "--recursive-prefix"

From
Glen Choo <chooglen@google.com>
Date
Jun 30, 2022, 22:11 UTC
Message-ID
<20220630221147.45689-1-chooglen@google.com>
In-Reply-To
<pull.1282.v2.git.git.1656623978.gitgitgadget@gmail.com>

(resending as v3 because I accidentally included ab/submodule-cleanup in v2)

Thanks Ævar for the feedback! I've incorporated all of the suggestions, except breaking up the tests in 1/6 into their own patch - I wasn't convinced of the value of having prescriptive tests (with test_expect_failure), and I found it difficult to discuss descriptive tests (with test_expect_success) without also having the code in the same diff. FWIW, this version (and the previous one) "git rebase -x 'make test'" cleanly :)

Note for Junio: this version is based on ab/submodule-cleanup (and so will future versions).

= Description

This series is a refactor of "git submodule--helper update" that replaces "--recursive-prefix" with "--super-prefix" (see Background). This was initially motivated by:

 * Junio's suggestion to simplify the code [1] (in response to a memory leak
   found by Johannes Schindelin [2]).
 * A desire to use the module_list API + get_submodule_displaypath() outside
   of builtin/submodule--helper.c (I expect to use this to check out
   branches in each submodule).

But it also happens to remove some overly complicated/duplicated code that was literally converted from shell :)

= Background

When recursing into nested submodules, Git commands keep track of the path from the superproject to the submodule in order to print a "display path" to the user, e.g.

  Submodule path '../super/sub/nested-sub': checked out 'abcdef'

For historical reasons, "git submodule--helper update" uses "--recursive-prefix" for this purpose, but it should use "--super-prefix" instead because:

 * That's what every other command uses (not just submodule--helper
   subcommands).
 * Using the "--super-prefix" helper functions makes the "git
   submodule--helper update" code simpler
= Patch organization
 * Patch 1/6 makes sure that display paths are only computed using display
   path helper functions ([do_]get_submodule_displaypath()) and fixes some
   display paths that we never realized were broken.
 * Patches 2-3/6 simplify and deduplicate some display path computations.
 * Patch 4/6 (authored by Ævar) removes SUPPORT_SUPER_PREFIX where it's not
   needed.
   * This doesn't affect correctness, but we want to do this eventually, so
     do it now to make 5/6 a bit cleaner.
 * Patch 5/6 replaces "--recursive-prefix" with "--super-prefix", making
   do_get_submodule_displaypath() obsolete.
   * GGG outputs an odd diff; I recommend viewing it with "--histogram"
 * Patch 6/6 removes do_get_submodule_displaypath().
= Series history
Changes in v3:
* None (resend of v2 because v2 accidentally included
  ab/submodule-cleanup)
Changes in v2:
 * Rebase onto ab/submodule-cleanup (previously master)
 * Cherry pick https://github.com/avar/git/commit/f445c57490d into 4/6
 * Style fixes in .c and tests
= Future work

At the end of this series, get_submodule_displaypath() can be moved to submodule.h, which would make submodule.c:get_super_prefix_or_empty() obsolete. I have a patch that demonstrates this (CI run: [4]), but I decided to keep this series more focused on "git submodule--helper update" so that it's easier to review.

[1] https://lore.kernel.org/git/xmqq35g5xmmv.fsf@gitster.g [2] https://lore.kernel.org/git/877a45867ae368bf9e053caedcb6cf421e02344d.1655336146.git.gitgitgadget@gmail.com [3] https://lore.kernel.org/git/patch-v3-02.12-082e015781e-20220622T142012Z-avarab@gmail.com [4] https://github.com/chooglen/git/actions/runs/2572557584

Glen Choo (5):
  submodule--helper update: use display path helper
  submodule--helper: don't recreate recursive prefix
  submodule--helper: use correct display path helper
  submodule--helper update: use --super-prefix
  submodule--helper: remove display path helper
Ævar Arnfjörð Bjarmason (1):
  submodule--helper: remove unused SUPPORT_SUPER_PREFIX flags
 builtin/submodule--helper.c | 87 ++++++++++---------------------------
 t/t7406-submodule-update.sh | 56 ++++++++++++++++++++++++
 2 files changed, 79 insertions(+), 64 deletions(-)
Range-diff against v1:
1:  473548f2fa ! 1:  64c138df19 submodule--helper update: use display path helper
    @@ builtin/submodule--helper.c: static int prepare_to_clone_next_submodule(const st
     -	struct strbuf displaypath_sb = STRBUF_INIT;
      	struct strbuf sb = STRBUF_INIT;
     -	const char *displaypath = NULL;
    -+	char *displaypath = NULL;
    ++	char *displaypath;
      	int needs_cloning = 0;
      	int need_free_url = 0;
      
    @@ builtin/submodule--helper.c: static int prepare_to_clone_next_submodule(const st
     -		else
     -			strbuf_addstr(&sb, ce->name);
     -		strbuf_addf(out, _("Skipping unmerged submodule %s"), sb.buf);
    --		strbuf_addch(out, '\n');
    -+		strbuf_addf(out, _("Skipping unmerged submodule '%s'\n"), displaypath);
    ++		strbuf_addf(out, _("Skipping unmerged submodule %s"), displaypath);
    + 		strbuf_addch(out, '\n');
      		goto cleanup;
      	}
      
    @@ t/t7406-submodule-update.sh: test_expect_success 'submodule update --filter sets
     +	test_when_finished "rm -fr top-cloned" &&
     +	cp -r top-clean top-cloned &&
     +
    -+	# Create an upstream commit in each repo
    ++	# Create an upstream commit in each repo, starting with bottom
     +	test_commit -C bottom upstream_commit &&
    -+	(cd middle &&
    -+	 git -C bottom fetch &&
    -+	 git -C bottom checkout -f FETCH_HEAD &&
    -+	 git add bottom &&
    -+	 git commit -m "upstream_commit"
    -+	) &&
    -+	(cd top &&
    -+	 git -C middle fetch &&
    -+	 git -C middle checkout -f FETCH_HEAD &&
    -+	 git add middle &&
    -+	 git commit -m "upstream_commit"
    -+	) &&
    ++	# Create middle commit
    ++	git -C middle/bottom fetch &&
    ++	git -C middle/bottom checkout -f FETCH_HEAD &&
    ++	git -C middle add bottom &&
    ++	git -C middle commit -m "upstream_commit" &&
    ++	# Create top commit
    ++	git -C top/middle fetch &&
    ++	git -C top/middle checkout -f FETCH_HEAD &&
    ++	git -C top add middle &&
    ++	git -C top commit -m "upstream_commit" &&
     +
     +	# Create a downstream conflict
    -+	(cd top-cloned/middle &&
    -+	 test_commit -C bottom downstream_commit &&
    -+	 git add bottom &&
    -+	 git commit -m "downstream_commit" &&
    -+	 git fetch --recurse-submodules origin &&
    -+	 test_must_fail git merge origin/main
    -+	) &&
    ++	test_commit -C top-cloned/middle/bottom downstream_commit &&
    ++	git -C top-cloned/middle add bottom &&
    ++	git -C top-cloned/middle commit -m "downstream_commit" &&
    ++	git -C top-cloned/middle fetch --recurse-submodules origin &&
    ++	test_must_fail git -C top-cloned/middle merge origin/main &&
    ++
     +	# Make the update of "middle" a no-op, otherwise we error out
     +	# because of its unmerged state
     +	test_config -C top-cloned submodule.middle.update !true &&
     +	git -C top-cloned submodule update --recursive 2>actual.err &&
    -+	grep "Skipping unmerged submodule .middle/bottom." actual.err
    ++	grep -F "Skipping unmerged submodule middle/bottom" actual.err
     +'
     +
     +test_expect_success 'submodule update --recursive skip submodules with strategy=none' '
    @@ t/t7406-submodule-update.sh: test_expect_success 'submodule update --filter sets
     +	test_commit -C top-cloned/middle/bottom downstream_commit &&
     +	git -C top-cloned/middle config submodule.bottom.update none &&
     +	git -C top-cloned submodule update --recursive 2>actual.err &&
    -+	grep "Skipping submodule .middle/bottom." actual.err
    ++	grep -F "Skipping submodule ${SQ}middle/bottom${SQ}" actual.err
     +'
     +
      test_done
2:  618053730e ! 2:  d3e803a463 submodule--helper: don't recreate recursive prefix
    @@ Commit message
     
      ## builtin/submodule--helper.c ##
     @@ builtin/submodule--helper.c: static void update_data_to_args(struct update_data *update_data, struct strvec *
    - {
    + 
      	strvec_pushl(args, "submodule--helper", "update", "--recursive", NULL);
      	strvec_pushf(args, "--jobs=%d", update_data->max_jobs);
     -	if (update_data->recursive_prefix)
3:  7cd1c46f35 = 3:  1f7cf6ffaf submodule--helper: use correct display path helper
-:  ---------- > 4:  85e65f143b submodule--helper: remove unused SUPPORT_SUPER_PREFIX flags
4:  57988287fc ! 5:  1d8b6b244d submodule--helper update: use --super-prefix
    @@ builtin/submodule--helper.c: struct submodule_update_clone {
      	const char *prefix;
     -	const char *recursive_prefix;
      	const char *displaypath;
    - 	const char *update_default;
    + 	enum submodule_update_type update_default;
      	struct object_id suboid;
     @@ builtin/submodule--helper.c: static int prepare_to_clone_next_submodule(const struct cache_entry *ce,
      
    @@ builtin/submodule--helper.c: static int prepare_to_clone_next_submodule(const st
     +						   get_super_prefix());
      
      	if (ce_stage(ce)) {
    - 		strbuf_addf(out, _("Skipping unmerged submodule '%s'\n"), displaypath);
    -@@ builtin/submodule--helper.c: static void ensure_core_worktree(const char *path)
    - 
    - static void update_data_to_args(struct update_data *update_data, struct strvec *args)
    + 		strbuf_addf(out, _("Skipping unmerged submodule %s"), displaypath);
    +@@ builtin/submodule--helper.c: static void update_data_to_args(struct update_data *update_data, struct strvec *
      {
    + 	enum submodule_update_type update_type = update_data->update_default;
    + 
     -	strvec_pushl(args, "submodule--helper", "update", "--recursive", NULL);
     -	strvec_pushf(args, "--jobs=%d", update_data->max_jobs);
      	if (update_data->displaypath)
    @@ builtin/submodule--helper.c: static int module_update(int argc, const char **arg
     -			   N_("path"),
     -			   N_("path into the working tree, across nested "
     -			      "submodule boundaries")),
    - 		OPT_STRING(0, "update", &opt.update_default,
    - 			   N_("string"),
    - 			   N_("rebase, merge, checkout or none")),
    + 		OPT_SET_INT(0, "checkout", &opt.update_default,
    + 			N_("use the 'checkout' update strategy (default)"),
    + 			SM_UPDATE_CHECKOUT),
     @@ builtin/submodule--helper.c: static int module_update(int argc, const char **argv, const char *prefix)
      			module_list_active(&list);
      
    @@ builtin/submodule--helper.c: struct cmd_struct {
      	{"name", module_name, 0},
     -	{"clone", module_clone, 0},
     +	{"clone", module_clone, SUPPORT_SUPER_PREFIX},
    - 	{"add", module_add, SUPPORT_SUPER_PREFIX},
    + 	{"add", module_add, 0},
     -	{"update", module_update, 0},
     +	{"update", module_update, SUPPORT_SUPER_PREFIX},
      	{"resolve-relative-url-test", resolve_relative_url_test, 0},
      	{"foreach", module_foreach, SUPPORT_SUPER_PREFIX},
    - 	{"init", module_init, SUPPORT_SUPER_PREFIX},
    + 	{"init", module_init, 0},
5:  9fa13380b0 ! 6:  a21e8cd174 submodule--helper: remove display path helper
    @@ builtin/submodule--helper.c: static int prepare_to_clone_next_submodule(const st
     +		get_submodule_displaypath(ce->name, suc->update_data->prefix);
      
      	if (ce_stage(ce)) {
    - 		strbuf_addf(out, _("Skipping unmerged submodule '%s'\n"), displaypath);
    + 		strbuf_addf(out, _("Skipping unmerged submodule %s"), displaypath);
     @@ builtin/submodule--helper.c: static int update_submodule(struct update_data *update_data)
      {
      	ensure_core_worktree(update_data->sm_path);
base-commit: 5b893f7d81eb7feb43662ed8663e2af76a76b4c8
-- 
2.37.0.rc0.161.g10f37bed90-goog
Previous: Glen ChooNext: Glen Choo
Message 32 of 48 in “submodule: remove "--recursive-prefix"”
  1. 0/5 submodule: remove "--recursive-prefix"Glen Choo via GitGitGadget, Jun 27, 2022
  2. 1/5 submodule--helper update: use display path helperGlen Choo via GitGitGadget, Jun 27, 2022
  3. Ævar Arnfjörð BjarmasonJun 28, 2022
  4. Glen ChooJun 28, 2022
  5. 2/5 submodule--helper: don't recreate recursive prefixGlen Choo via GitGitGadget, Jun 27, 2022
  6. 3/5 submodule--helper: use correct display path helperGlen Choo via GitGitGadget, Jun 27, 2022
  7. 4/5 submodule--helper update: use --super-prefixGlen Choo via GitGitGadget, Jun 27, 2022
  8. Ævar Arnfjörð BjarmasonJun 28, 2022
  9. Glen ChooJun 28, 2022
  10. 5/5 submodule--helper: remove display path helperGlen Choo via GitGitGadget, Jun 27, 2022
  11. Glen ChooJun 28, 2022
  12. 00/18 submodule: remove "--recursive-prefix"Glen Choo via GitGitGadget, Jun 30, 2022
  13. 01/18 git-submodule.sh: remove unused sanitize_submodule_env()Ævar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  14. 02/18 git-submodule.sh: remove unused $prefix variableÆvar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  15. 03/18 git-submodule.sh: make the "$cached" variable a booleanÆvar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  16. 04/18 git-submodule.sh: remove unused top-level "--branch" argumentÆvar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  17. 05/18 submodule--helper: have --require-init imply --initÆvar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  18. 06/18 submodule update: remove "-v" optionÆvar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  19. 07/18 submodule--helper: rename "absorb-git-dirs" to "absorbgitdirs"Ævar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  20. 08/18 submodule--helper: report "submodule" as our name in some "-h" outputÆvar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  21. 09/18 submodule--helper: understand --checkout, --merge and --rebase synonymsÆvar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  22. 10/18 submodule--helper: eliminate internal "--update" optionGlen Choo via GitGitGadget, Jun 30, 2022
  23. 11/18 git-submodule.sh: use "$quiet", not "$GIT_QUIET"Ævar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  24. 12/18 git-sh-setup.sh: remove "say" function, change last usersÆvar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  25. 13/18 submodule--helper update: use display path helperGlen Choo via GitGitGadget, Jun 30, 2022
  26. 14/18 submodule--helper: don't recreate recursive prefixGlen Choo via GitGitGadget, Jun 30, 2022
  27. 15/18 submodule--helper: use correct display path helperGlen Choo via GitGitGadget, Jun 30, 2022
  28. 16/18 submodule--helper: remove unused SUPPORT_SUPER_PREFIX flagsÆvar Arnfjörð Bjarmason via GitGitGadget, Jun 30, 2022
  29. 18/18 submodule--helper: remove display path helperGlen Choo via GitGitGadget, Jun 30, 2022
  30. 17/18 submodule--helper update: use --super-prefixGlen Choo via GitGitGadget, Jun 30, 2022
  31. Glen ChooJun 30, 2022
  32. 0/6 submodule: remove "--recursive-prefix"Glen Choo, Jun 30, 2022
  33. 1/6 submodule--helper update: use display path helperGlen Choo, Jun 30, 2022
  34. 2/6 submodule--helper: don't recreate recursive prefixGlen Choo, Jun 30, 2022
  35. 3/6 submodule--helper: use correct display path helperGlen Choo, Jun 30, 2022
  36. 4/6 submodule--helper: remove unused SUPPORT_SUPER_PREFIX flagsGlen Choo, Jun 30, 2022
  37. 5/6 submodule--helper update: use --super-prefixGlen Choo, Jun 30, 2022
  38. 6/6 submodule--helper: remove display path helperGlen Choo, Jun 30, 2022
  39. 0/7 submodule: remove "--recursive-prefix"Glen Choo, Jul 1, 2022
  40. 1/7 submodule--helper tests: add missing "display path" coverageGlen Choo, Jul 1, 2022
  41. 2/7 submodule--helper update: use display path helperGlen Choo, Jul 1, 2022
  42. 3/7 submodule--helper: don't recreate recursive prefixGlen Choo, Jul 1, 2022
  43. 4/7 submodule--helper: use correct display path helperGlen Choo, Jul 1, 2022
  44. 6/7 submodule--helper update: use --super-prefixGlen Choo, Jul 1, 2022
  45. 5/7 submodule--helper: remove unused SUPPORT_SUPER_PREFIX flagsGlen Choo, Jul 1, 2022
  46. 7/7 submodule--helper: remove display path helperGlen Choo, Jul 1, 2022
  47. Ævar Arnfjörð BjarmasonJun 30, 2022
  48. Glen ChooJun 30, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.