Re: [RFC PATCH 2/2] crypto sign: add cryptoSign.* config
- From
Fabian Stelzer <fs@gigacodes.de>
- Date
- Dec 21, 2021, 09:39 UTC
- Message-ID
- <20211221093941.53ks5gnbkxl7vkn6@fs>
- In-Reply-To
- <CAPig+cRGnMQaDj-qocpAbhQqyksCNqGub+LsspWf7-Dwy=TKzg@mail.gmail.com>
On 20.12.2021 17:07, Eric Sunshine wrote:
Show 43 quoted lines
>`On Mon, Dec 20, 2021 at 9:09 AM Fabian Stelzer <fs@gigacodes.de> wrote: >> Since git now supports multiple cryptographic methods/formats to sign >> objects, the `gpg.` configuration prefix is misleading. >> Add `cryptoSign.`, but keep `gpg.` as a compatibility alias at least for >> all existing options. >> `gpg.mintrustlevel` is moved to `cryptosign.gpg.mintrustlevel` while >> also still allowing the former. >> --- >> diff --git a/Documentation/config/gpg.txt b/Documentation/config/gpg.txt >> @@ -1,6 +1,17 @@ >> +cryptoSign.format:: >> +gpg.format:: >> + Specifies which key format to use when signing with `--crypto-sign`. >> + Default is "openpgp". Other possible values are "x509", "ssh". >> + >> +cryptoSign.<format>.program:: >> +gpg.<format>.program:: >> + Use this to customize the program used for the signing format you >> + chose (see `cryptoSign.format`). The default value for > >This is a somewhat minor comment, but I find that grouping these >config keys together like this gives too much weight to the old >`gpg.foo` ones, making it seem as if they're still first-class >citizens which people can use freely. If you instead organize them as >below, then it is easier to see at a glance that the old keys >shouldn't be used: > > cryptoSign.format:: > Specifies which key format to use when signing... > > cryptoSign.<format>.program:: > Use this to customize the program used... > > ... > > gpg.format:: > Deprecated synonym of `cryptoSign.format`. > > gpg.<format>.program:: > Deprecated synonym of `cryptoSign.<format>.program`. > >The same observation about grouping of config keys applies to the >remainder of the documentation changes in this patch.
I wasn't sure how much we want to already deprecate the `gpg.` keys so I tried a gentle approach :) But I would be in favor of your variant.
Thanks