[RFC PATCH 0/2] cryptoSign flag & config
- From
Fabian Stelzer <fs@gigacodes.de>
- Date
- Dec 20, 2021, 14:09 UTC
- Message-ID
- <20211220140928.1205586-1-fs@gigacodes.de>
Since git now supports multiple methods for signing objects some of the existing flags and configuration variables can be misleading. Especially the flags could be understood as selecting a format (--gpg-sign), which they do not.
This series introduces the more generic name "cryptoSign". Using just "sign" could otherwise be too easily confused with "sign-off".
For now I have only adjusted the gpg-sign flag to a single command and added the new configuration prefix and would like to hear some feedback. If we can agree on the naming and implementation I will of course adjust all the other commands likewise and add some tests for the compatibility layer. The `(commit|tag|push).gpgsign` var is still on my todo list as well.
My earlier question to the list (<xmqqzgpn50l6.fsf@gitster.g>) did not receive much feedback so i'm sending this rfc patch.
Fabian Stelzer (2): crypto sign: add crypto-sign alias flag crypto sign: add cryptoSign.* config
Documentation/config/gpg.txt | 31 ++++++++++++++++++++----------- Documentation/git-commit.txt | 15 ++++++++++----- builtin/commit.c | 5 ++++- gpg-interface.c | 30 ++++++++++++++++++++++-------- 4 files changed, 56 insertions(+), 25 deletions(-)
-- 2.33.1