Re: [PATCH] push: unset PARSE_OPT_OPTARG for --recurse-submodules
- From
Jeff King <peff@peff.net>
- Date
- Apr 27, 2020, 12:02 UTC
- Message-ID
- <20200427120225.GB1718141@coredump.intra.peff.net>
- In-Reply-To
- <c2b92691ca85029fde3bd6969252cc827ca697b5.1587969824.git.liu.denton@gmail.com>
On Mon, Apr 27, 2020 at 02:44:08AM -0400, Denton Liu wrote:
Show 17 quoted lines
> When the usage for `git push` is shown, it includes the following > lines > > --recurse-submodules[=(check|on-demand|no)] > control recursive pushing of submodules > > which seem to indicate that the argument for --recurse-submodules is > optional. However, we cannot actually run that optiion without an > argument: > > $ git push --recurse-submodules > fatal: recurse-submodules missing parameter > > Unset PARSE_OPT_OPTARG so that it is clear that this option requires an > argument. Since the parse-options machinery guarantees that an argument > is present now, assume that `arg` is set in the else of > option_parse_recurse_submodules().
Yeah, I think this is the right solution. It looks like it was broken since the option was introduced in d2b17b3220 (push: Don't push a repository with unpushed submodules, 2011-08-20).
I wondered if it was copied from another similar option in another command, and if so whether that option had the same problem. But it doesn't look like it. The other --recurse-submodules options are all PARSE_OPT_OPTARG, but they actually do something useful when they are not given an option (they turn it to "on").
I don't know enough about the "push" case to say whether it would be a good idea for it to behave similarly, but certainly your patch is an improvement until somebody decides to look into it.
Show 13 quoted lines
> diff --git a/builtin/push.c b/builtin/push.c
> index 6dbf0f0bb7..90f071fcf2 100644
> --- a/builtin/push.c
> +++ b/builtin/push.c
> @@ -434,10 +434,8 @@ static int option_parse_recurse_submodules(const struct option *opt,
>
> if (unset)
> *recurse_submodules = RECURSE_SUBMODULES_OFF;
> - else if (arg)
> - *recurse_submodules = parse_push_recurse_submodules_arg(opt->long_name, arg);
> else
> - die("%s missing parameter", opt->long_name);
> + *recurse_submodules = parse_push_recurse_submodules_arg(opt->long_name, arg);What a lousy diff. It would be much easier to read if we chose to replace the "else" and keep the big complicated line intact. :) Both Myers and --histogram give the diff above, but --patience gives:
diff --git a/builtin/push.c b/builtin/push.c index 6dbf0f0bb7..ac6cc07c8c 100644 --- a/builtin/push.c +++ b/builtin/push.c @@ -434,10 +434,8 @@ static int option_parse_recurse_submodules(const struct option *opt, if (unset) *recurse_submodules = RECURSE_SUBMODULES_OFF; - else if (arg) + else *recurse_submodules = parse_push_recurse_submodules_arg(opt->long_name, arg); - else - die("%s missing parameter", opt->long_name); return 0; } Obviously not a complaint about your patch. I'm always just curious to see cases where the various diff implementations do better or worse than each other. > @@ -554,7 +552,7 @@ int cmd_push(int argc, const char **argv, const char *prefix) > PARSE_OPT_OPTARG | PARSE_OPT_LITERAL_ARGHELP, parseopt_push_cas_option }, > { OPTION_CALLBACK, 0, "recurse-submodules", &recurse_submodules, "(check|on-demand|no)", > N_("control recursive pushing of submodules"), > - PARSE_OPT_OPTARG, option_parse_recurse_submodules }, > + 0, option_parse_recurse_submodules }, This could collapse down to OPT_CALLBACK() now, though I don't think it's a big deal either way. -Peff