git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 0/3] t6025: updating tests

From
Shourya Shukla <shouryashukla.oo@gmail.com>
Date
Jan 16, 2020, 20:36 UTC
Message-ID
<20200116203622.4694-1-shouryashukla.oo@gmail.com>
Greetings everyone!

This is my first ever contribution in the Open-Source Community and I chose Git for this purpose as I have been using this important tool to maintain my projects regularly.

In this patch, I have:
  - modernized these tests so that they meet current Git CodingGuidlines[1]
  - replaced the pipe operator with the redirection operator so that one can
	detect the errors easily and precisely
  - used helper function 'test_path_is_file()' to replace 'test -f' checks in
	in the program as it improves the readability of the code and provides 
	better error messages
Also, I have some questions to better my understanding of the code:
	- In the statement, 
		> git hash-object -t blob -w --stdin
	  is it necessary to explicitly specify the type 'blob' of the hash-object?
	  I have this question because it is the default type of hash-object.
	- In the statement, 
		> l=$(printf file | git hash-object -t blob -w --stdin)
	  I have not used the redirection operator as this sub-shell will be executed 
	  separately, hence its error cannot be captured therefore the presence of '>' 
	  will not matter. Will using '>' improve the code?

Thanks, Shourya Shukla

Shourya Shukla (3):
  t6025: modernize style
  t6025: replace pipe with redirection operator
  t6025: use helpers to replace test -f <path>
 t/t6025-merge-symlinks.sh | 97 ++++++++++++++++++++-------------------
 1 file changed, 50 insertions(+), 47 deletions(-)
-- 
2.20.1
Next: Shourya Shukla
Message 1 of 24 in “t6025: updating tests”
  1. 0/3 t6025: updating testsShourya Shukla, Jan 16, 2020
  2. 1/3 t6025: modernize styleShourya Shukla, Jan 16, 2020
  3. Johannes SchindelinJan 16, 2020
  4. 2/3 t6025: replace pipe with redirection operatorShourya Shukla, Jan 16, 2020
  5. Junio C HamanoJan 16, 2020
  6. 3/3 t6025: use helpers to replace test -f <path>Shourya Shukla, Jan 16, 2020
  7. Junio C HamanoJan 16, 2020
  8. 0/3 t6025: amended changes after suggestions from the communityShourya Shukla, Jan 17, 2020
  9. 1/3 t6025: modernize styleShourya Shukla, Jan 17, 2020
  10. Eric SunshineJan 17, 2020
  11. Junio C HamanoJan 17, 2020
  12. 2/3 t6025: replace pipe with redirection operatorShourya Shukla, Jan 17, 2020
  13. Eric SunshineJan 17, 2020
  14. 0/3 t6025: updating testsShourya Shukla, Jan 18, 2020
  15. 1/3 t6025: modernize styleShourya Shukla, Jan 18, 2020
  16. 2/3 t6025: replace pipe with redirection operatorShourya Shukla, Jan 18, 2020
  17. 3/3 t6025: use helpers to replace test -f <path>Shourya Shukla, Jan 18, 2020
  18. 0/2 t025: amended changes after suggestions from the communityShourya Shukla, Jan 18, 2020
  19. 1/2 t6025: modernize styleShourya Shukla, Jan 18, 2020
  20. Junio C HamanoJan 21, 2020
  21. 2/2 t6025: use helpers to replace test -f <path>Shourya Shukla, Jan 18, 2020
  22. Junio C HamanoJan 21, 2020
  23. 3/3 t6025: use helpers to replace test -f <path>Shourya Shukla, Jan 17, 2020
  24. Johannes SchindelinJan 16, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.