Re: [PATCH v3 3/9] ewah/bitmap: introduce bitmap_word_alloc()
On Wed, Dec 11, 2019 at 02:50:40PM +0100, Christian Couder wrote:
Show 5 quoted lines
> > I wonder if "new_with_world_alloc" or "new_with_size" would make it more
> > obvious that this is also a constructor, though.
>
> bitmap_new_with_word_alloc() feels a bit verbose to me for such a
> short function, so for now I kept bitmap_word_alloc().
OK, that's fine with me...
> I think that if we really want to use "new" for constructors then a
> better solution would be something like renaming bitmap_new(void) to
> bitmap_new_default(void) and bitmap_word_alloc(size_t word_alloc) to
> bitmap_new(size_t word_alloc).
...but that also would be fine with me.
-Peff