Re: [PATCH v1 3/5] list-objects-filter: implement composite filters
- From
Jeff King <peff@peff.net>
- Date
- Jun 4, 2019, 18:51 UTC
- Message-ID
- <20190604185108.GA14738@sigill.intra.peff.net>
- In-Reply-To
- <20190604171952.GI4641@comcast.net>
On Tue, Jun 04, 2019 at 10:19:52AM -0700, Matthew DeVore wrote:
Show 13 quoted lines
> On Tue, Jun 04, 2019 at 12:13:32PM -0400, Jeff King wrote: > > > - return has_reserved_character(subspec, errbuf) || > > > - url_decode(subspec, errbuf) || > > > - gently_parse_list_objects_filter( > > > - &filter_options->sub[new_index], subspec->buf, errbuf); > > > + decoded = url_percent_decode(subspec->buf); > > > > I think you can get rid of has_reserved_character() now, too. > > The purpose of has_reserved_character is to allow for future > extensibility if someone decides to implement a more sophisticated DSL > and give meaning to these characters. That may be a long-shot, but it > seems worth it.
I think you'll find that -Wunused-function complains, though, if nobody is calling it. I wasn't sure if what you showed in the interdiff was meant to be final (I had to add a few other variable declarations to make it compile, too).
Show 13 quoted lines
> > The reserved character list is still used on the encoding side. But I > > think you could switch to strbuf_add_urlencode() there? > > strbuf_addstr_urlencode will either escape or not escape all rfc3986 > reserved characters, and that set includes both : and +. The former > should not require escaping since it's a common character in filter > specs, and I would like the hand-encoded combine specs to be relatively > easy to type and read. The + must be escaped since it is used as part of > the combine:... syntax to delimit sub filters. So > strbuf_addstr_url_encode would have to be more customizable to make it > work for this context. I'd like to add a parameterizable should_escape > predicate (iow function pointer) which strbuf_addstr_urlencode accepts. > I actually think this will be more readable than the current strbuf API.
That makes some sense, and I agree that readability is a good goal. Do we not need to be escaping colons in other URLs? Or are the strings you're generating not true by-the-book URLs? I'm just wondering if we could take this opportunity to improve the URLs we output elsewhere, too.
-Peff