git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v4 00/11] Many promisor remotes

From
Christian Couder <christian.couder@gmail.com>
Date
Apr 1, 2019, 16:40 UTC
Message-ID
<20190401164045.17328-1-chriscool@tuxfamily.org>

This path series is a follow up from the "remote odb" patch series that I sent last year, which were a follow up from previous series. See the links section for more information.

The goal of this patch series is to make it possible to have and to fetch missing objects from multiple remotes instead of only one.

For now the fetch order is the order of the remotes in the config, except for the remote specified by extensions.partialclone config option which comes last in the fetch order.

I selected the name "Promisor remote" over "Partial clone remote" because it is shorter and because it is not only about cloning.

The existing extensions.partialclone config option is respected, but it is not written in the config when a partial clone or fetch is made. Instead remote.<name>.promisor is set to "true". This may create a compatibility issue, but it makes it possible to start using many promisor remotes by just cloning and fetching from different remotes with partial clone filters. The compatibility issue could be resolved in a future iteration by just setting extensions.partialclone instead of remote.<name>.promisor the first time a promisor remote is used.

The code might not work with many promisor remotes that don't all have all the promised objects, as that would require the fetch protocol to send packs with best effort, as described by Junio in:

https://public-inbox.org/git/xmqqpnqve71d.fsf@gitster-ct.c.googlers.com/
In general I have tried to change as few things as possible.

High level changes since the V3 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

The number of patches didn't change. Their title and purpose didn't change either.

The changes were all suggested by Junio.
everywhere:
  - changed name of promisor remote variables from "o" to "r"
patch 2/11:
  - made promisor_remote_new() static
  - changed promisor_remote_look_up() to promisor_remote_lookup()
  - changed struct promisor_remote to use a flex array
  - added check that promisor remote names doesn't start with "/"
patch 3/11:
  - implemented fetching only what is still missing
  - removed trailing blank line
4/11:
  - made "initialized" file static instead of function static
  - added purge of promisor remote list in promisor_remote_reinit()
5/11:
  - improve commit message

High level overview of this patch series ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

  - Patch 1/11:

This patch, makes functions in fetch-object.c return an error code, which is necessary to later tell that they failed and try another promisor remote when there is more than one. This could also just be seen as a fix to these functions.

  - Patch 2/11:
This introduces the minimum infrastructure for promisor remotes.
  - Patch 3/11, 4/11 and 5/11:

This add a few missing bits in the promisor remote infrastructure that will be needed in the following patches.

  - Patch 6/11:

This replaces the previous interface that used only one promisor remote defined in extensions.partialclone with the new interface created by the previous patches.

  - Patch 7/11:

This replaces the way a partial clone filter was handled by a new way based on the previous patches that support more than one partial clone filter.

  - Patch 8/11:

This patch removes the limitation in builtin/fetch.c to have only one promisor remote.

  - Patch 9/11:

This adds test cases that shows that now more than one promisor remote can be used and that remote.<name>.promisor is set to "true" when fetching from a new promisor remote.

  - Patch 10/11 and 11/11:

These documentation patches explain how things can work with more than one promisor remote.

Links ~~~~~

This patch series on GitHub:
V3: https://github.com/chriscool/git/commits/many-promisor-remotes
V3: https://github.com/chriscool/git/commits/many-promisor-remotes40
V2: https://github.com/chriscool/git/commits/many-promisor-remotes35
V1: https://github.com/chriscool/git/commits/many-promisor-remotes17
On the mailing list:
V3: https://public-inbox.org/git/20190312132959.11764-1-chriscool@tuxfamily.org/
V2: https://public-inbox.org/git/20190122144212.15119-1-chriscool@tuxfamily.org/
V1: https://public-inbox.org/git/20181211052746.16218-1-chriscool@tuxfamily.org/

This patch series is a follow up from the discussions related to the remote odb V4 patch series:

https://public-inbox.org/git/20180802061505.2983-1-chriscool@tuxfamily.org/
Especially in:
https://public-inbox.org/git/CAP8UFD3nrhjANwNDqTwx5ZtnZNcnbAFqUN=u=LrvzuH4+3wQQA@mail.gmail.com/
I said that I would like to work on things in the following order:
  1) Teaching partial clone to attempt to fetch missing objects from
multiple remotes instead of only one using the order in the config.
  2) Simplifying the protocol for fetching missing objects so that it
can be satisfied by a lighter weight object storage system than a full
Git server.
  3) Making it possible to explicitly define an order in which the
remotes are accessed.
  4) Making the criteria for what objects can be missing more
aggressive, so that I can "git add" a large file and work with it
using Git without even having a second copy of that object in my local
object store.
And this patch series is about the 1).
The previous remote odb patch series on GitHub:
V5: https://github.com/chriscool/git/commits/remote-odb
V4: https://github.com/chriscool/git/commits/remote-odb5
V3: https://github.com/chriscool/git/commits/remote-odb3
V2: https://github.com/chriscool/git/commits/remote-odb2
V1: https://github.com/chriscool/git/commits/remote-odb1
Discussions related to previous versions of the odb patch series:
V4: https://public-inbox.org/git/20180802061505.2983-1-chriscool@tuxfamily.org/
V3: https://public-inbox.org/git/20180713174959.16748-1-chriscool@tuxfamily.org/
V2: https://public-inbox.org/git/20180630083542.20347-1-chriscool@tuxfamily.org/
V1: https://public-inbox.org/git/20180623121846.19750-1-chriscool@tuxfamily.org/
Christian Couder (11):
  fetch-object: make functions return an error code
  Add initial support for many promisor remotes
  promisor-remote: implement promisor_remote_get_direct()
  promisor-remote: add promisor_remote_reinit()
  promisor-remote: use repository_format_partial_clone
  Use promisor_remote_get_direct() and has_promisor_remote()
  promisor-remote: parse remote.*.partialclonefilter
  builtin/fetch: remove unique promisor remote limitation
  t0410: test fetching from many promisor remotes
  partial-clone: add multiple remotes in the doc
  remote: add promisor and partial clone config to the doc
 Documentation/config/remote.txt           |   8 +
 Documentation/technical/partial-clone.txt |  83 ++++++---
 Makefile                                  |   1 +
 builtin/cat-file.c                        |   5 +-
 builtin/fetch.c                           |  29 +--
 builtin/gc.c                              |   3 +-
 builtin/repack.c                          |   3 +-
 cache-tree.c                              |   3 +-
 connected.c                               |   3 +-
 fetch-object.c                            |  13 +-
 fetch-object.h                            |   4 +-
 list-objects-filter-options.c             |  51 +++---
 list-objects-filter-options.h             |   3 +-
 packfile.c                                |   3 +-
 promisor-remote.c                         | 212 ++++++++++++++++++++++
 promisor-remote.h                         |  21 +++
 sha1-file.c                               |  14 +-
 t/t0410-partial-clone.sh                  |  49 ++++-
 t/t5601-clone.sh                          |   3 +-
 t/t5616-partial-clone.sh                  |   4 +-
 unpack-trees.c                            |   6 +-
 21 files changed, 425 insertions(+), 96 deletions(-)
 create mode 100644 promisor-remote.c
 create mode 100644 promisor-remote.h
-- 
2.21.0.203.gd44fa53258
Next: Christian Couder
Message 1 of 18 in “Many promisor remotes”
  1. 00/11 Many promisor remotesChristian Couder, Apr 1, 2019
  2. 01/11 fetch-object: make functions return an error codeChristian Couder, Apr 1, 2019
  3. 02/11 Add initial support for many promisor remotesChristian Couder, Apr 1, 2019
  4. SZEDER GáborApr 3, 2019
  5. Christian CouderApr 4, 2019
  6. 03/11 promisor-remote: implement promisor_remote_get_direct()Christian Couder, Apr 1, 2019
  7. 04/11 promisor-remote: add promisor_remote_reinit()Christian Couder, Apr 1, 2019
  8. 05/11 promisor-remote: use repository_format_partial_cloneChristian Couder, Apr 1, 2019
  9. 06/11 Use promisor_remote_get_direct() and has_promisor_remote()Christian Couder, Apr 1, 2019
  10. 07/11 promisor-remote: parse remote.*.partialclonefilterChristian Couder, Apr 1, 2019
  11. 08/11 builtin/fetch: remove unique promisor remote limitationChristian Couder, Apr 1, 2019
  12. 09/11 t0410: test fetching from many promisor remotesChristian Couder, Apr 1, 2019
  13. SZEDER GáborApr 5, 2019
  14. 10/11 partial-clone: add multiple remotes in the docChristian Couder, Apr 1, 2019
  15. 11/11 remote: add promisor and partial clone config to the docChristian Couder, Apr 1, 2019
  16. Junio C HamanoApr 4, 2019
  17. Christian CouderApr 4, 2019
  18. Johannes SchindelinApr 5, 2019

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.