git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 1/3] clone: use a more appropriate variable name for the default refspec

From
Jeff King <peff@peff.net>
Date
Nov 15, 2018, 10:54 UTC
Message-ID
<20181115105427.GA19032@sigill.intra.peff.net>
In-Reply-To
<20181114104620.32478-2-szeder.dev@gmail.com>
On Wed, Nov 14, 2018 at 11:46:18AM +0100, SZEDER Gábor wrote:
Show 9 quoted lines
> cmd_clone() declares two strbufs 'key' and 'value' on the same line,
> suggesting that they are used to contruct a config variable's name and
> value.  However, this is not the case: 'key' is used to construct the
> names of multiple config variables, while 'value' is never used as a
> value for any of those config variables, or for any other config
> variable for that matter, but only to contruct the default fetch
> refspec.
> 
> Let's rename 'value' to 'default_refspec' to make the intent clearer.
Yep, this is much nicer.
-Peff
Previous: SZEDER GáborNext: SZEDER Gábor
Message 3 of 9 in “clone: respect configured fetch respecs during initial fetch”
  1. 0/3 clone: respect configured fetch respecs during initial fetchSZEDER Gábor, Nov 14, 2018
  2. 1/3 clone: use a more appropriate variable name for the default refspecSZEDER Gábor, Nov 14, 2018
  3. Jeff KingNov 15, 2018
  4. 2/3 clone: respect additional configured fetch refspecs during initial fetchSZEDER Gábor, Nov 14, 2018
  5. Jeff KingNov 15, 2018
  6. 3/3 Documentation/clone: document ignored configuration variablesSZEDER Gábor, Nov 14, 2018
  7. Jeff KingNov 15, 2018
  8. Jeff KingNov 15, 2018
  9. Junio C HamanoNov 16, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.