From: Jeff King Date: Thu, 15 Nov 2018 10:54:27 GMT Subject: Re: [PATCH 1/3] clone: use a more appropriate variable name for the default refspec Message-ID: <20181115105427.GA19032@sigill.intra.peff.net> In-Reply-To: <20181114104620.32478-2-szeder.dev@gmail.com> On Wed, Nov 14, 2018 at 11:46:18AM +0100, SZEDER Gábor wrote: > cmd_clone() declares two strbufs 'key' and 'value' on the same line, > suggesting that they are used to contruct a config variable's name and > value. However, this is not the case: 'key' is used to construct the > names of multiple config variables, while 'value' is never used as a > value for any of those config variables, or for any other config > variable for that matter, but only to contruct the default fetch > refspec. > > Let's rename 'value' to 'default_refspec' to make the intent clearer. Yep, this is much nicer. -Peff