Re: [PATCH 0/1] rebase: understand -C again, refactor
- From
Jeff King <peff@peff.net>
- Date
- Nov 14, 2018, 07:29 UTC
- Message-ID
- <20181114072909.GD19904@sigill.intra.peff.net>
- In-Reply-To
- <pull.76.git.gitgitgadget@gmail.com>
On Tue, Nov 13, 2018 at 04:38:24AM -0800, Johannes Schindelin via GitGitGadget wrote:
Show 5 quoted lines
> Phillip Wood reported a problem where the built-in rebase did not understand > options like -C1, i.e. it did not expect the option argument. > > While investigating how to address this best, I stumbled upon > OPT_PASSTHRU_ARGV (which I was so far happily unaware of).
I was unaware of it, too. Looking at the OPT_PASSTHRU and its ARGV counterpart, I think the original intent was that you'd pass through normal last-one-wins individual options with OPT_PASSTHRU, and then list-like options with OPT_PASSTHRU_ARGV. But here you've used the latter to pass sets of individual last-one-wins options.
That said, I think what you've done here is way simpler and more readable than using a bunch of OPT_PASSTHRUs would have been. And even if it was not the original intent of the ARGV variant, I can't see any reason to avoid doing it this way.
-Peff