Re: [PATCH 3/3] cat-file: handle streaming failures consistently
- From
Jeff King <peff@peff.net>
- Date
- Oct 31, 2018, 14:37 UTC
- Message-ID
- <20181031143747.GA9994@sigill.intra.peff.net>
- In-Reply-To
- <xmqqva5iurd7.fsf@gitster-ct.c.googlers.com>
On Wed, Oct 31, 2018 at 11:23:48PM +0900, Junio C Hamano wrote:
Show 11 quoted lines
> Torsten Bögershausen <tboegi@web.de> writes: > > >> +static int stream_blob(const struct object_id *oid) > > > > Sorry for nit-picking: > > could this be renamed into stream_blob_to_stdout() ? > > I think that name makes sense, even though stream_blob() is just > fine for a fuction that takes a single parameter oid, as there is no > other sane choice than streaming to the standard output stream the > blob data.
I was trying to keep the name small since it is a static-local convenience helper. I'd rather write it as:
stream_blob(1, oid);
than change the name. ;)
Show 12 quoted lines
> >> +{
> >> + if (stream_blob_to_fd(1, oid, NULL, 0))
> >
> > And I wonder if we could make things clearer:
> > s/1/STDOUT_FILENO/
>
> What would benefit from symbolic constant more in that function call
> may be CAN_SEEK thing, but s/1/STDOUT_FILENO/ adds negative value to
> that line, I would think. The name of the function already makes it
> clear this is sending the output to a file descriptor, and an
> integer 1 that specifies a file descriptor cannot mean anything
> other than the standard output stream.Yes, I'd agree (there are very few cases where I think STDOUT_FILENO actually increases the readability, since it is usually pretty clear from the context when something is a descriptor).
-Peff