git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v7 00/10] Make submodules work if .gitmodules is not checked out

From
Antonio Ospite <ao2@ao2.it>
Date
Oct 25, 2018, 16:18 UTC
Message-ID
<20181025161813.17252-1-ao2@ao2.it>
Hi,

this series teaches git to try and read the .gitmodules file from the index (:.gitmodules) or from the current branch (HEAD:.gitmodules) when the file is not readily available in the working tree.

This can be used, together with sparse checkouts, to enable submodule usage with programs like vcsh[1] which manage multiple repositories with their working trees sharing the same path.

[1] https://github.com/RichiH/vcsh

In the previous series there were some comments about not using the enum in patch 8, but I decided to leave the code as it was as I still think that it make sense to use an enum there, and have the default value unnamed; during the discussion I pointed out that other code in git do the same.

In this series I am addressing the comments by Stefan Beller about the tests in patch 9.

If the new tests look OK, I'd say we try moving the series to "next" and see what happens?

I am available to address any further concerns in follow-up patches.

v6 of the series is here: https://public-inbox.org/git/20181005130601.15879-1-ao2@ao2.it/

v5 of the series is here: https://public-inbox.org/git/20180917140940.3839-1-ao2@ao2.it/

v4 of the series is here: https://public-inbox.org/git/20180824132951.8000-1-ao2@ao2.it/

v3 of the series is here: https://public-inbox.org/git/20180814110525.17801-1-ao2@ao2.it/

v2 of the series is here: https://public-inbox.org/git/20180802134634.10300-1-ao2@ao2.it/

v1 of the series, with some background info, is here: https://public-inbox.org/git/20180514105823.8378-1-ao2@ao2.it/

Changes since v6:
  * Renamed t7416-submodule-sparse-gitmodules.sh to
    t7418-submodule-sparse-gitmodules.sh because t7416 was already
    taken.  This has been already taken care of by Junio in "pu".
  * Improved tests in t7418: now, instead of just testing the return
    value of "git submodule ..." commands when .gitmodules is not in the
    working tree, the actual use case is checked in each test, with pre-
    and post-conditions.
Thank you,
   Antonio
Antonio Ospite (10):
  submodule: add a print_config_from_gitmodules() helper
  submodule: factor out a config_set_in_gitmodules_file_gently function
  t7411: merge tests 5 and 6
  t7411: be nicer to future tests and really clean things up
  submodule--helper: add a new 'config' subcommand
  submodule: use the 'submodule--helper config' command
  t7506: clean up .gitmodules properly before setting up new scenario
  submodule: add a helper to check if it is safe to write to .gitmodules
  submodule: support reading .gitmodules when it's not in the working
    tree
  t/helper: add test-submodule-nested-repo-config
 Makefile                                     |   1 +
 builtin/grep.c                               |  17 ++-
 builtin/submodule--helper.c                  |  40 ++++++
 cache.h                                      |   2 +
 git-submodule.sh                             |  13 +-
 submodule-config.c                           |  68 ++++++++-
 submodule-config.h                           |   2 +
 submodule.c                                  |  28 +++-
 submodule.h                                  |   1 +
 t/helper/test-submodule-nested-repo-config.c |  30 ++++
 t/helper/test-tool.c                         |   1 +
 t/helper/test-tool.h                         |   1 +
 t/t7411-submodule-config.sh                  | 141 +++++++++++++++++--
 t/t7418-submodule-sparse-gitmodules.sh       | 122 ++++++++++++++++
 t/t7506-status-submodule.sh                  |   3 +-
 t/t7814-grep-recurse-submodules.sh           |  16 +++
 16 files changed, 454 insertions(+), 32 deletions(-)
 create mode 100644 t/helper/test-submodule-nested-repo-config.c
 create mode 100755 t/t7418-submodule-sparse-gitmodules.sh
-- 
Antonio Ospite
https://ao2.it
https://twitter.com/ao2it

A: Because it messes up the order in which people normally read text.
   See http://en.wikipedia.org/wiki/Posting_style
Q: Why is top-posting such a bad thing?
Next: Antonio Ospite
Message 1 of 17 in “Make submodules work if .gitmodules is not checked out”
  1. 00/10 Make submodules work if .gitmodules is not checked outAntonio Ospite, Oct 25, 2018
  2. 01/10 submodule: add a print_config_from_gitmodules() helperAntonio Ospite, Oct 25, 2018
  3. 05/10 submodule--helper: add a new 'config' subcommandAntonio Ospite, Oct 25, 2018
  4. 04/10 t7411: be nicer to future tests and really clean things upAntonio Ospite, Oct 25, 2018
  5. 09/10 submodule: support reading .gitmodules when it's not in the working treeAntonio Ospite, Oct 25, 2018
  6. Johannes SchindelinOct 30, 2018
  7. Antonio OspiteOct 30, 2018
  8. Junio C HamanoOct 31, 2018
  9. 07/10 t7506: clean up .gitmodules properly before setting up new scenarioAntonio Ospite, Oct 25, 2018
  10. 06/10 submodule: use the 'submodule--helper config' commandAntonio Ospite, Oct 25, 2018
  11. 08/10 submodule: add a helper to check if it is safe to write to .gitmodulesAntonio Ospite, Oct 25, 2018
  12. 10/10 t/helper: add test-submodule-nested-repo-configAntonio Ospite, Oct 25, 2018
  13. 02/10 submodule: factor out a config_set_in_gitmodules_file_gently functionAntonio Ospite, Oct 25, 2018
  14. 03/10 t7411: merge tests 5 and 6Antonio Ospite, Oct 25, 2018
  15. Stefan BellerOct 25, 2018
  16. Junio C HamanoOct 26, 2018
  17. Stefan BellerOct 26, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.