[PATCH 07/25] t5406: use write_script() instead of birthing shell script manually
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Jul 2, 2018, 00:23 UTC
- Message-ID
- <20180702002405.3042-8-sunshine@sunshineco.com>
- In-Reply-To
- <20180702002405.3042-1-sunshine@sunshineco.com>
Take advantage of write_script() to abstract-away details of shell script creation, thus allowing the reader to focus on script content. Readability benefits, particularly in this case, since the script body was buried in a noisy one-liner subshell responsible for emitting boilerplate and body.
Signed-off-by: Eric Sunshine <sunshine@sunshineco.com> --- t/t5406-remote-rejects.sh | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/t/t5406-remote-rejects.sh b/t/t5406-remote-rejects.sh index 59e80a5ea2..ff06f99649 100755 --- a/t/t5406-remote-rejects.sh +++ b/t/t5406-remote-rejects.sh @@ -6,8 +6,9 @@ test_description='remote push rejects are reported by client' test_expect_success 'setup' ' mkdir .git/hooks && - (echo "#!/bin/sh" ; echo "exit 1") >.git/hooks/update && - chmod +x .git/hooks/update && + write_script .git/hooks/update <<-\EOF && + exit 1 + EOF echo 1 >file && git add file && git commit -m 1 &&
-- 2.18.0.203.gfac676dfb9