git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 1/3] completion: rename save_opts to default_opts for stash

From
Thomas Gummerer <t.gummerer@gmail.com>
Date
Apr 17, 2018, 21:29 UTC
Message-ID
<20180417212945.24002-2-t.gummerer@gmail.com>
In-Reply-To
<20180417212945.24002-1-t.gummerer@gmail.com>

'git stash save' is deprecated, but we still call the options for completion 'save_opts'. Simply renaming them to 'push_opts' is not ideal because for example '--message foo' can't be passed directly to 'git stash', as non-option arguments are not allowed, and foo would be treated as one.

Completing '--message' in 'git stash --<tab>' would end up being quite confusing for the user. Therefore name them 'default_opts', and keep treating --message specially for 'git stash push'.

The ulterior motive for renaming 'save_opts' is that in the next commit we're going to stop completing 'git stash save', so 'save_opts' would be the only remaining thing referring to 'git stash save', which would probably be confusing for future readers of this code.

Signed-off-by: Thomas Gummerer <t.gummerer@gmail.com>
---
 contrib/completion/git-completion.bash | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/contrib/completion/git-completion.bash b/contrib/completion/git-completion.bash
index a757073945..39c123926c 100644
--- a/contrib/completion/git-completion.bash
+++ b/contrib/completion/git-completion.bash
@@ -2773,16 +2773,16 @@ _git_show_branch ()
 
 _git_stash ()
 {
-	local save_opts='--all --keep-index --no-keep-index --quiet --patch --include-untracked'
+	local default_opts='--all --keep-index --no-keep-index --quiet --patch --include-untracked'
 	local subcommands='push save list show apply clear drop pop create branch'
 	local subcommand="$(__git_find_on_cmdline "$subcommands")"
 	if [ -z "$subcommand" ]; then
 		case "$cur" in
 		--*)
-			__gitcomp "$save_opts"
+			__gitcomp "$default_opts"
 			;;
 		*)
-			if [ -z "$(__git_find_on_cmdline "$save_opts")" ]; then
+			if [ -z "$(__git_find_on_cmdline "$default_opts")" ]; then
 				__gitcomp "$subcommands"
 			fi
 			;;
@@ -2790,10 +2790,10 @@ _git_stash ()
 	else
 		case "$subcommand,$cur" in
 		push,--*)
-			__gitcomp "$save_opts --message"
+			__gitcomp "$default_opts --message"
 			;;
 		save,--*)
-			__gitcomp "$save_opts"
+			__gitcomp "$default_opts"
 			;;
 		apply,--*|pop,--*)
 			__gitcomp "--index --quiet"
-- 
2.17.0.252.gfe0a9eaf31
Previous: Thomas GummererNext: Thomas Gummerer
Message 2 of 12 in “completion: improvements for git stash”
  1. 0/3 completion: improvements for git stashThomas Gummerer, Apr 17, 2018
  2. 1/3 completion: rename save_opts to default_opts for stashThomas Gummerer, Apr 17, 2018
  3. 2/3 completion: stop completing 'save' as stash subcommandThomas Gummerer, Apr 17, 2018
  4. 3/3 completion: make stash -p and alias for stash push -pThomas Gummerer, Apr 17, 2018
  5. Junio C HamanoApr 18, 2018
  6. Thomas GummererApr 18, 2018
  7. 0/2 completion: improvements for git stashThomas Gummerer, Apr 19, 2018
  8. 1/2 completion: stop showing 'save' for stash by defaultThomas Gummerer, Apr 19, 2018
  9. Duy NguyenApr 20, 2018
  10. Thomas GummererApr 22, 2018
  11. 2/2 completion: make stash -p and alias for stash push -pThomas Gummerer, Apr 19, 2018
  12. Junio C HamanoApr 20, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.