Re: [PATCH v2 0/5] roll back locks in various code paths
- From
Jeff King <peff@peff.net>
- Date
- Mar 2, 2018, 10:49 UTC
- Message-ID
- <20180302104904.GC11074@sigill.intra.peff.net>
- In-Reply-To
- <20180301204020.24406-1-martin.agren@gmail.com>
On Thu, Mar 01, 2018 at 09:40:20PM +0100, Martin Ågren wrote:
Show 9 quoted lines
> After thinking about it, I tend to agree. That rewrite loses an > indentation level and makes it a bit clearer that we have two steps, > "maybe bail" and "write". But at the cost of duplicating logic -- after > all, those two steps are very closely related, so there's no need to > artificially separate them. > > Here it is again, without that hunk, and without the commit message > claim that it'd be a good thing to have just a few uses of > "active_cache_changed" remaining.
Thanks, this version looks good to me. The name SKIP_IF_UNCHANGED is generic and may result in clashes down the road. But then so is the name COMMIT_LOCK. I'm OK to punt on that until we do see such a collision, at which point we may want to provide a consistent namespace for these flags.
-Peff