git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v8 28/29] merge-recursive: avoid spurious rename/rename conflict from dir renames

From
Elijah Newren <newren@gmail.com>
Date
Feb 14, 2018, 18:52 UTC
Message-ID
<20180214185206.15492-29-newren@gmail.com>
In-Reply-To
<20180214185206.15492-1-newren@gmail.com>

If a file on one side of history was renamed, and merely modified on the other side, then applying a directory rename to the modified side gives us a rename/rename(1to2) conflict. We should only apply directory renames to pairs representing either adds or renames.

Making this change means that a directory rename testcase that was previously reported as a rename/delete conflict will now be reported as a modify/delete conflict.

Reviewed-by: Stefan Beller <sbeller@google.com>
Signed-off-by: Elijah Newren <newren@gmail.com>
---
 merge-recursive.c                   |  4 +--
 t/t6043-merge-rename-directories.sh | 55 +++++++++++++++++--------------------
 2 files changed, 27 insertions(+), 32 deletions(-)
diff --git a/merge-recursive.c b/merge-recursive.c
index 6ff54c0e86..5063caabe1 100644
--- a/merge-recursive.c
+++ b/merge-recursive.c
@@ -1991,7 +1991,7 @@ static void compute_collisions(struct hashmap *collisions,
 		char *new_path;
 		struct diff_filepair *pair = pairs->queue[i];
 
-		if (pair->status == 'D')
+		if (pair->status != 'A' && pair->status != 'R')
 			continue;
 		dir_rename_ent = check_dir_renamed(pair->two->path,
 						   dir_renames);
@@ -2218,7 +2218,7 @@ static struct string_list *get_renames(struct merge_options *o,
 		struct diff_filepair *pair = pairs->queue[i];
 		char *new_path; /* non-NULL only with directory renames */
 
-		if (pair->status == 'D') {
+		if (pair->status != 'A' && pair->status != 'R') {
 			diff_free_filepair(pair);
 			continue;
 		}
diff --git a/t/t6043-merge-rename-directories.sh b/t/t6043-merge-rename-directories.sh
index 5b84591445..45f620633f 100755
--- a/t/t6043-merge-rename-directories.sh
+++ b/t/t6043-merge-rename-directories.sh
@@ -2078,18 +2078,23 @@ test_expect_success '8b-check: Dual-directory rename, one into the others way, w
 	)
 '
 
-# Testcase 8c, rename+modify/delete
-#   (Related to testcases 5b and 8d)
+# Testcase 8c, modify/delete or rename+modify/delete?
+#   (Related to testcases 5b, 8d, and 9h)
 #   Commit O: z/{b,c,d}
 #   Commit A: y/{b,c}
 #   Commit B: z/{b,c,d_modified,e}
-#   Expected: y/{b,c,e}, CONFLICT(rename+modify/delete: x/d -> y/d or deleted)
+#   Expected: y/{b,c,e}, CONFLICT(modify/delete: on z/d)
 #
-#   Note: This testcase doesn't present any concerns for me...until you
-#         compare it with testcases 5b and 8d.  See notes in 8d for more
-#         details.
-
-test_expect_success '8c-setup: rename+modify/delete' '
+#   Note: It could easily be argued that the correct resolution here is
+#         y/{b,c,e}, CONFLICT(rename/delete: z/d -> y/d vs deleted)
+#         and that the modifed version of d should be present in y/ after
+#         the merge, just marked as conflicted.  Indeed, I previously did
+#         argue that.  But applying directory renames to the side of
+#         history where a file is merely modified results in spurious
+#         rename/rename(1to2) conflicts -- see testcase 9h.  See also
+#         notes in 8d.
+
+test_expect_success '8c-setup: modify/delete or rename+modify/delete?' '
 	test_create_repo 8c &&
 	(
 		cd 8c &&
@@ -2122,32 +2127,32 @@ test_expect_success '8c-setup: rename+modify/delete' '
 	)
 '
 
-test_expect_success '8c-check: rename+modify/delete' '
+test_expect_success '8c-check: modify/delete or rename+modify/delete' '
 	(
 		cd 8c &&
 
 		git checkout A^0 &&
 
 		test_must_fail git merge -s recursive B^0 >out &&
-		test_i18ngrep "CONFLICT (rename/delete).* z/d.*y/d" out &&
+		test_i18ngrep "CONFLICT (modify/delete).* z/d" out &&
 
 		git ls-files -s >out &&
-		test_line_count = 4 out &&
+		test_line_count = 5 out &&
 		git ls-files -u >out &&
-		test_line_count = 1 out &&
+		test_line_count = 2 out &&
 		git ls-files -o >out &&
 		test_line_count = 1 out &&
 
 		git rev-parse >actual \
-			:0:y/b :0:y/c :0:y/e :3:y/d &&
+			:0:y/b :0:y/c :0:y/e :1:z/d :3:z/d &&
 		git rev-parse >expect \
-			 O:z/b  O:z/c  B:z/e  B:z/d &&
+			 O:z/b  O:z/c  B:z/e  O:z/d  B:z/d &&
 		test_cmp expect actual &&
 
-		test_must_fail git rev-parse :1:y/d &&
-		test_must_fail git rev-parse :2:y/d &&
-		git ls-files -s y/d | grep ^100755 &&
-		test_path_is_file y/d
+		test_must_fail git rev-parse :2:z/d &&
+		git ls-files -s z/d | grep ^100755 &&
+		test_path_is_file z/d &&
+		test_path_is_missing y/d
 	)
 '
 
@@ -2161,16 +2166,6 @@ test_expect_success '8c-check: rename+modify/delete' '
 #
 #   Note: It would also be somewhat reasonable to resolve this as
 #             y/{b,c,e}, CONFLICT(rename/delete: x/d -> y/d or deleted)
-#   The logic being that the only difference between this testcase and 8c
-#   is that there is no modification to d.  That suggests that instead of a
-#   rename/modify vs. delete conflict, we should just have a rename/delete
-#   conflict, otherwise we are being inconsistent.
-#
-#   However...as far as consistency goes, we didn't report a conflict for
-#   path d_1 in testcase 5b due to a different file being in the way.  So,
-#   we seem to be forced to have cases where users can change things
-#   slightly and get what they may perceive as inconsistent results.  It
-#   would be nice to avoid that, but I'm not sure I see how.
 #
 #   In this case, I'm leaning towards: commit A was the one that deleted z/d
 #   and it did the rename of z to y, so the two "conflicts" (rename vs.
@@ -2915,7 +2910,7 @@ test_expect_success '9h-setup: Avoid dir rename on merely modified path' '
 	)
 '
 
-test_expect_failure '9h-check: Avoid dir rename on merely modified path' '
+test_expect_success '9h-check: Avoid dir rename on merely modified path' '
 	(
 		cd 9h &&
 
@@ -3959,7 +3954,7 @@ test_expect_success '12c-setup: Moving one directory hierarchy into another w/ c
 	)
 '
 
-test_expect_failure '12c-check: Moving one directory hierarchy into another w/ content merge' '
+test_expect_success '12c-check: Moving one directory hierarchy into another w/ content merge' '
 	(
 		cd 12c &&
 
-- 
2.16.1.232.g28d5be9217
Previous: Elijah NewrenNext: Elijah Newren
Message 27 of 31 in “Add directory rename detection to git”
  1. 00/29 Add directory rename detection to gitElijah Newren, Feb 14, 2018
  2. 02/29 directory rename detection: directory splitting testcasesElijah Newren, Feb 14, 2018
  3. 17/29 merge-recursive: make a helper function for cleanup for handle_renamesElijah Newren, Feb 14, 2018
  4. 26/29 merge-recursive: fix remaining directory rename + dirty overwrite casesElijah Newren, Feb 14, 2018
  5. 19/29 merge-recursive: check for directory level conflictsElijah Newren, Feb 14, 2018
  6. 18/29 merge-recursive: add get_directory_renames()Elijah Newren, Feb 14, 2018
  7. 05/29 directory rename detection: files/directories in the way of some renamesElijah Newren, Feb 14, 2018
  8. 09/29 directory rename detection: miscellaneous testcases to complete coverageElijah Newren, Feb 14, 2018
  9. 16/29 merge-recursive: split out code for determining diff_filepairsElijah Newren, Feb 14, 2018
  10. 12/29 merge-recursive: move the get_renames() functionElijah Newren, Feb 14, 2018
  11. 15/29 merge-recursive: make !o->detect_rename codepath more obviousElijah Newren, Feb 14, 2018
  12. 11/29 directory rename detection: tests for handling overwriting dirty filesElijah Newren, Feb 14, 2018
  13. 04/29 directory rename detection: partially renamed directory testcase/discussionElijah Newren, Feb 14, 2018
  14. 01/29 directory rename detection: basic testcasesElijah Newren, Feb 14, 2018
  15. 06/29 directory rename detection: testcases checking which side did the renameElijah Newren, Feb 14, 2018
  16. 29/29 merge-recursive: ensure we write updates for directory-renamed fileElijah Newren, Feb 14, 2018
  17. 22/29 merge-recursive: when comparing files, don't include treesElijah Newren, Feb 14, 2018
  18. 03/29 directory rename detection: testcases to avoid taking detection too farElijah Newren, Feb 14, 2018
  19. 07/29 directory rename detection: more involved edge/corner testcasesElijah Newren, Feb 14, 2018
  20. 13/29 merge-recursive: introduce new functions to handle rename logicElijah Newren, Feb 14, 2018
  21. 23/29 merge-recursive: apply necessary modifications for directory renamesElijah Newren, Feb 14, 2018
  22. 24/29 merge-recursive: avoid clobbering untracked files with directory renamesElijah Newren, Feb 14, 2018
  23. 14/29 merge-recursive: fix leaks of allocated renames and diff_filepairsElijah Newren, Feb 14, 2018
  24. 20/29 merge-recursive: add computation of collisions due to dir rename & mergingElijah Newren, Feb 14, 2018
  25. 27/29 directory rename detection: new testcases showcasing a pair of bugsElijah Newren, Feb 14, 2018
  26. 08/29 directory rename detection: testcases exploring possibly suboptimal mergesElijah Newren, Feb 14, 2018
  27. 28/29 merge-recursive: avoid spurious rename/rename conflict from dir renamesElijah Newren, Feb 14, 2018
  28. 25/29 merge-recursive: fix overwriting dirty files involved in renamesElijah Newren, Feb 14, 2018
  29. 10/29 directory rename detection: tests for handling overwriting untracked filesElijah Newren, Feb 14, 2018
  30. 21/29 merge-recursive: check for file level conflicts then get new nameElijah Newren, Feb 14, 2018
  31. Stefan BellerFeb 14, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.