git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v8 17/29] merge-recursive: make a helper function for cleanup for handle_renames

From
Elijah Newren <newren@gmail.com>
Date
Feb 14, 2018, 18:51 UTC
Message-ID
<20180214185206.15492-18-newren@gmail.com>
In-Reply-To
<20180214185206.15492-1-newren@gmail.com>

In anticipation of more involved cleanup to come, make a helper function for doing the cleanup at the end of handle_renames. Rename the already existing cleanup_rename[s]() to final_cleanup_rename[s](), name the new helper initial_cleanup_rename(), and leave the big comment in the code about why we can't do all the cleanup at once.

Reviewed-by: Stefan Beller <sbeller@google.com>
Signed-off-by: Elijah Newren <newren@gmail.com>
---
 merge-recursive.c | 23 +++++++++++++----------
 1 file changed, 13 insertions(+), 10 deletions(-)
diff --git a/merge-recursive.c b/merge-recursive.c
index db8833675e..be20660527 100644
--- a/merge-recursive.c
+++ b/merge-recursive.c
@@ -1667,6 +1667,12 @@ struct rename_info {
 	struct string_list *merge_renames;
 };
 
+static void initial_cleanup_rename(struct diff_queue_struct *pairs)
+{
+	free(pairs->queue);
+	free(pairs);
+}
+
 static int handle_renames(struct merge_options *o,
 			  struct tree *common,
 			  struct tree *head,
@@ -1697,16 +1703,13 @@ static int handle_renames(struct merge_options *o,
 	 * data structures are still needed and referenced in
 	 * process_entry().  But there are a few things we can free now.
 	 */
-
-	free(head_pairs->queue);
-	free(head_pairs);
-	free(merge_pairs->queue);
-	free(merge_pairs);
+	initial_cleanup_rename(head_pairs);
+	initial_cleanup_rename(merge_pairs);
 
 	return clean;
 }
 
-static void cleanup_rename(struct string_list *rename)
+static void final_cleanup_rename(struct string_list *rename)
 {
 	const struct rename *re;
 	int i;
@@ -1722,10 +1725,10 @@ static void cleanup_rename(struct string_list *rename)
 	free(rename);
 }
 
-static void cleanup_renames(struct rename_info *re_info)
+static void final_cleanup_renames(struct rename_info *re_info)
 {
-	cleanup_rename(re_info->head_renames);
-	cleanup_rename(re_info->merge_renames);
+	final_cleanup_rename(re_info->head_renames);
+	final_cleanup_rename(re_info->merge_renames);
 }
 
 static struct object_id *stage_oid(const struct object_id *oid, unsigned mode)
@@ -2128,7 +2131,7 @@ int merge_trees(struct merge_options *o,
 		}
 
 cleanup:
-		cleanup_renames(&re_info);
+		final_cleanup_renames(&re_info);
 
 		string_list_clear(entries, 1);
 		free(entries);
-- 
2.16.1.232.g28d5be9217
Previous: Elijah NewrenNext: Elijah Newren
Message 3 of 31 in “Add directory rename detection to git”
  1. 00/29 Add directory rename detection to gitElijah Newren, Feb 14, 2018
  2. 02/29 directory rename detection: directory splitting testcasesElijah Newren, Feb 14, 2018
  3. 17/29 merge-recursive: make a helper function for cleanup for handle_renamesElijah Newren, Feb 14, 2018
  4. 26/29 merge-recursive: fix remaining directory rename + dirty overwrite casesElijah Newren, Feb 14, 2018
  5. 19/29 merge-recursive: check for directory level conflictsElijah Newren, Feb 14, 2018
  6. 18/29 merge-recursive: add get_directory_renames()Elijah Newren, Feb 14, 2018
  7. 05/29 directory rename detection: files/directories in the way of some renamesElijah Newren, Feb 14, 2018
  8. 09/29 directory rename detection: miscellaneous testcases to complete coverageElijah Newren, Feb 14, 2018
  9. 16/29 merge-recursive: split out code for determining diff_filepairsElijah Newren, Feb 14, 2018
  10. 12/29 merge-recursive: move the get_renames() functionElijah Newren, Feb 14, 2018
  11. 15/29 merge-recursive: make !o->detect_rename codepath more obviousElijah Newren, Feb 14, 2018
  12. 11/29 directory rename detection: tests for handling overwriting dirty filesElijah Newren, Feb 14, 2018
  13. 04/29 directory rename detection: partially renamed directory testcase/discussionElijah Newren, Feb 14, 2018
  14. 01/29 directory rename detection: basic testcasesElijah Newren, Feb 14, 2018
  15. 06/29 directory rename detection: testcases checking which side did the renameElijah Newren, Feb 14, 2018
  16. 29/29 merge-recursive: ensure we write updates for directory-renamed fileElijah Newren, Feb 14, 2018
  17. 22/29 merge-recursive: when comparing files, don't include treesElijah Newren, Feb 14, 2018
  18. 03/29 directory rename detection: testcases to avoid taking detection too farElijah Newren, Feb 14, 2018
  19. 07/29 directory rename detection: more involved edge/corner testcasesElijah Newren, Feb 14, 2018
  20. 13/29 merge-recursive: introduce new functions to handle rename logicElijah Newren, Feb 14, 2018
  21. 23/29 merge-recursive: apply necessary modifications for directory renamesElijah Newren, Feb 14, 2018
  22. 24/29 merge-recursive: avoid clobbering untracked files with directory renamesElijah Newren, Feb 14, 2018
  23. 14/29 merge-recursive: fix leaks of allocated renames and diff_filepairsElijah Newren, Feb 14, 2018
  24. 20/29 merge-recursive: add computation of collisions due to dir rename & mergingElijah Newren, Feb 14, 2018
  25. 27/29 directory rename detection: new testcases showcasing a pair of bugsElijah Newren, Feb 14, 2018
  26. 08/29 directory rename detection: testcases exploring possibly suboptimal mergesElijah Newren, Feb 14, 2018
  27. 28/29 merge-recursive: avoid spurious rename/rename conflict from dir renamesElijah Newren, Feb 14, 2018
  28. 25/29 merge-recursive: fix overwriting dirty files involved in renamesElijah Newren, Feb 14, 2018
  29. 10/29 directory rename detection: tests for handling overwriting untracked filesElijah Newren, Feb 14, 2018
  30. 21/29 merge-recursive: check for file level conflicts then get new nameElijah Newren, Feb 14, 2018
  31. Stefan BellerFeb 14, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.