git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH v3 32/33] merge-recursive: avoid spurious rename/rename conflict from dir renames

From
Elijah Newren <newren@gmail.com>
Date
Nov 21, 2017, 08:00 UTC
Message-ID
<20171121080059.32304-33-newren@gmail.com>
In-Reply-To
<20171121080059.32304-1-newren@gmail.com>

If a file on one side of history was renamed, and merely modified on the other side, then applying a directory rename to the modified side gives us a rename/rename(1to2) conflict. We should only apply directory renames to pairs representing either adds or renames.

Making this change means that a directory rename testcase that was previously reported as a rename/delete conflict will now be reported as a modify/delete conflict.

Signed-off-by: Elijah Newren <newren@gmail.com>
---
 merge-recursive.c                   |  4 +--
 t/t6043-merge-rename-directories.sh | 55 +++++++++++++++++--------------------
 2 files changed, 27 insertions(+), 32 deletions(-)
diff --git a/merge-recursive.c b/merge-recursive.c
index eaa50e6413..65cc997e93 100644
--- a/merge-recursive.c
+++ b/merge-recursive.c
@@ -1957,7 +1957,7 @@ static void compute_collisions(struct hashmap *collisions,
 		char *new_path;
 		struct diff_filepair *pair = pairs->queue[i];
 
-		if (pair->status == 'D')
+		if (pair->status == 'D' || pair->status == 'M')
 			continue;
 		dir_rename_ent = check_dir_renamed(pair->two->path,
 						   dir_renames);
@@ -2184,7 +2184,7 @@ static struct string_list *get_renames(struct merge_options *o,
 		struct diff_filepair *pair = pairs->queue[i];
 		char *new_path; /* non-NULL only with directory renames */
 
-		if (pair->status == 'D') {
+		if (pair->status == 'D' || pair->status == 'M') {
 			diff_free_filepair(pair);
 			continue;
 		}
diff --git a/t/t6043-merge-rename-directories.sh b/t/t6043-merge-rename-directories.sh
index 224d266695..119d7f5d70 100755
--- a/t/t6043-merge-rename-directories.sh
+++ b/t/t6043-merge-rename-directories.sh
@@ -2000,18 +2000,23 @@ test_expect_success '8b-check: Dual-directory rename, one into the others way, w
 	)
 '
 
-# Testcase 8c, rename+modify/delete
-#   (Related to testcases 5b and 8d)
+# Testcase 8c, modify/delete or rename+modify/delete?
+#   (Related to testcases 5b, 8d, and 9h)
 #   Commit O: z/{b,c,d}
 #   Commit A: y/{b,c}
 #   Commit B: z/{b,c,d_modified,e}
-#   Expected: y/{b,c,e}, CONFLICT(rename+modify/delete: x/d -> y/d or deleted)
+#   Expected: y/{b,c,e}, CONFLICT(modify/delete: on z/d)
 #
-#   Note: This testcase doesn't present any concerns for me...until you
-#         compare it with testcases 5b and 8d.  See notes in 8d for more
-#         details.
-
-test_expect_success '8c-setup: rename+modify/delete' '
+#   Note: It could easily be argued that the correct resolution here is
+#         y/{b,c,e}, CONFLICT(rename/delete: z/d -> y/d vs deleted)
+#         and that the modifed version of d should be present in y/ after
+#         the merge, just marked as conflicted.  Indeed, I previously did
+#         argue that.  But applying directory renames to the side of
+#         history where a file is merely modified results in spurious
+#         rename/rename(1to2) conflicts -- see testcase 9h.  See also
+#         notes in 8d.
+
+test_expect_success '8c-setup: modify/delete or rename+modify/delete?' '
 	test_create_repo 8c &&
 	(
 		cd 8c &&
@@ -2044,29 +2049,29 @@ test_expect_success '8c-setup: rename+modify/delete' '
 	)
 '
 
-test_expect_success '8c-check: rename+modify/delete' '
+test_expect_success '8c-check: modify/delete or rename+modify/delete' '
 	(
 		cd 8c &&
 
 		git checkout A^0 &&
 
 		test_must_fail git merge -s recursive B^0 >out &&
-		test_i18ngrep "CONFLICT (rename/delete).* z/d.*y/d" out &&
+		test_i18ngrep "CONFLICT (modify/delete).* z/d" out &&
 
-		test 4 -eq $(git ls-files -s | wc -l) &&
-		test 1 -eq $(git ls-files -u | wc -l) &&
+		test 5 -eq $(git ls-files -s | wc -l) &&
+		test 2 -eq $(git ls-files -u | wc -l) &&
 		test 1 -eq $(git ls-files -o | wc -l) &&
 
 		git rev-parse >actual \
-			:0:y/b :0:y/c :0:y/e :3:y/d &&
+			:0:y/b :0:y/c :0:y/e :1:z/d :3:z/d &&
 		git rev-parse >expect \
-			O:z/b O:z/c B:z/e B:z/d &&
+			O:z/b O:z/c B:z/e O:z/d B:z/d &&
 		test_cmp expect actual &&
 
-		test_must_fail git rev-parse :1:y/d &&
-		test_must_fail git rev-parse :2:y/d &&
-		git ls-files -s y/d | grep ^100755 &&
-		test -f y/d
+		test_must_fail git rev-parse :2:z/d &&
+		git ls-files -s z/d | grep ^100755 &&
+		test -f z/d &&
+		! test -f y/d
 	)
 '
 
@@ -2080,16 +2085,6 @@ test_expect_success '8c-check: rename+modify/delete' '
 #
 #   Note: It would also be somewhat reasonable to resolve this as
 #             y/{b,c,e}, CONFLICT(rename/delete: x/d -> y/d or deleted)
-#   The logic being that the only difference between this testcase and 8c
-#   is that there is no modification to d.  That suggests that instead of a
-#   rename/modify vs. delete conflict, we should just have a rename/delete
-#   conflict, otherwise we are being inconsistent.
-#
-#   However...as far as consistency goes, we didn't report a conflict for
-#   path d_1 in testcase 5b due to a different file being in the way.  So,
-#   we seem to be forced to have cases where users can change things
-#   slightly and get what they may perceive as inconsistent results.  It
-#   would be nice to avoid that, but I'm not sure I see how.
 #
 #   In this case, I'm leaning towards: commit A was the one that deleted z/d
 #   and it did the rename of z to y, so the two "conflicts" (rename vs.
@@ -2802,7 +2797,7 @@ test_expect_success '9h-setup: Avoid dir rename on merely modified path' '
 	)
 '
 
-test_expect_failure '9h-check: Avoid dir rename on merely modified path' '
+test_expect_success '9h-check: Avoid dir rename on merely modified path' '
 	(
 		cd 9h &&
 
@@ -3783,7 +3778,7 @@ test_expect_success '12c-setup: Moving one directory hierarchy into another w/ c
 	)
 '
 
-test_expect_failure '12c-check: Moving one directory hierarchy into another w/ content merge' '
+test_expect_success '12c-check: Moving one directory hierarchy into another w/ content merge' '
 	(
 		cd 12c &&
 
-- 
2.15.0.309.g62ce55426d
Previous: Elijah NewrenNext: Elijah Newren
Message 32 of 48 in “Add directory rename detection to git”
  1. 00/33 Add directory rename detection to gitElijah Newren, Nov 21, 2017
  2. 10/33 directory rename detection: more involved edge/corner testcasesElijah Newren, Nov 21, 2017
  3. 21/33 merge-recursive: add get_directory_renames()Elijah Newren, Nov 21, 2017
  4. Johannes SchindelinNov 26, 2017
  5. Elijah NewrenNov 26, 2017
  6. 06/33 directory rename detection: testcases to avoid taking detection too farElijah Newren, Nov 21, 2017
  7. 15/33 merge-recursive: move the get_renames() functionElijah Newren, Nov 21, 2017
  8. 29/33 merge-recursive: fix overwriting dirty files involved in renamesElijah Newren, Nov 21, 2017
  9. 03/33 merge-recursive: add explanation for src_entry and dst_entryElijah Newren, Nov 21, 2017
  10. 22/33 merge-recursive: check for directory level conflictsElijah Newren, Nov 21, 2017
  11. Stefan BellerNov 22, 2017
  12. 25/33 merge-recursive: check for file level conflicts then get new nameElijah Newren, Nov 21, 2017
  13. Stefan BellerNov 22, 2017
  14. 24/33 merge-recursive: add computation of collisions due to dir rename & mergingElijah Newren, Nov 21, 2017
  15. 04/33 directory rename detection: basic testcasesElijah Newren, Nov 21, 2017
  16. 05/33 directory rename detection: directory splitting testcasesElijah Newren, Nov 21, 2017
  17. 20/33 merge-recursive: add a new hashmap for storing directory renamesElijah Newren, Nov 21, 2017
  18. 18/33 merge-recursive: make !o->detect_rename codepath more obviousElijah Newren, Nov 21, 2017
  19. 02/33 merge-recursive: fix logic ordering issueElijah Newren, Nov 21, 2017
  20. 19/33 merge-recursive: split out code for determining diff_filepairsElijah Newren, Nov 21, 2017
  21. 31/33 directory rename detection: new testcases showcasing a pair of bugsElijah Newren, Nov 21, 2017
  22. 11/33 directory rename detection: testcases exploring possibly suboptimal mergesElijah Newren, Nov 21, 2017
  23. Stefan BellerNov 22, 2017
  24. 23/33 merge-recursive: add a new hashmap for storing file collisionsElijah Newren, Nov 21, 2017
  25. 09/33 directory rename detection: testcases checking which side did the renameElijah Newren, Nov 21, 2017
  26. 16/33 merge-recursive: introduce new functions to handle rename logicElijah Newren, Nov 21, 2017
  27. 13/33 directory rename detection: tests for handling overwriting untracked filesElijah Newren, Nov 21, 2017
  28. 26/33 merge-recursive: when comparing files, don't include treesElijah Newren, Nov 21, 2017
  29. 28/33 merge-recursive: avoid clobbering untracked files with directory renamesElijah Newren, Nov 21, 2017
  30. 27/33 merge-recursive: apply necessary modifications for directory renamesElijah Newren, Nov 21, 2017
  31. 33/33 merge-recursive: ensure we write updates for directory-renamed fileElijah Newren, Nov 21, 2017
  32. 32/33 merge-recursive: avoid spurious rename/rename conflict from dir renamesElijah Newren, Nov 21, 2017
  33. 14/33 directory rename detection: tests for handling overwriting dirty filesElijah Newren, Nov 21, 2017
  34. 12/33 directory rename detection: miscellaneous testcases to complete coverageElijah Newren, Nov 21, 2017
  35. 17/33 merge-recursive: fix leaks of allocated renames and diff_filepairsElijah Newren, Nov 21, 2017
  36. 08/33 directory rename detection: files/directories in the way of some renamesElijah Newren, Nov 21, 2017
  37. 07/33 directory rename detection: partially renamed directory testcase/discussionElijah Newren, Nov 21, 2017
  38. 01/33 Tighten and correct a few testcases for merging and cherry-pickingElijah Newren, Nov 21, 2017
  39. 30/33 merge-recursive: fix remaining directory rename + dirty overwrite casesElijah Newren, Nov 21, 2017
  40. Stefan BellerNov 22, 2017
  41. Elijah NewrenNov 22, 2017
  42. Junio C HamanoNov 22, 2017
  43. Stefan BellerNov 22, 2017
  44. Elijah NewrenNov 23, 2017
  45. Adam DinwoodieNov 23, 2017
  46. Elijah NewrenNov 23, 2017
  47. Elijah NewrenNov 24, 2017
  48. Elijah NewrenNov 24, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.