Re: [PATCH 3/7] read_in_full: reset errno before reading
> On Mon, Sep 25, 2017 at 05:17:32PM -0700, Jonathan Nieder wrote:
Show 12 quoted lines
>> #ifndef EUNDERFLOW
>> # ifdef ENODATA
>> # define EUNDERFLOW ENODATA
>> # else
>> # define EUNDERFLOW ESPIPE
>> # endif
>> #endif
>
> Right, I think our mails just crossed but I'm leaning in this direction.
> I'd prefer to call it SHORT_READ_ERRNO or something, though. Your
> "#ifndef EUNDERFLOW" had me thinking that this was something that a real
> platform might have, but AFAICT you just made it up.
Agreed. Two of the risks of replying too quickly. :)
Jonathan