[PATCH/RFC] commit-template: improve readability of commit template
* Previously the commit template didn't separate the
distinct messages shown. This resulted in difficulty
in interpreting it's content. Add new lines to separate
the distinct parts of the template.
* Previously the warning about usage of explicit paths
without any options wasn't clear. Make it more clear
so user gets what it's trying to say.
Signed-off-by: Kaartic Sivaraam <kaarticsivaraam91196@gmail.com>
---
I've tried to improve the message specified in the commit. Hope
it works correctly.
Local test passed.
builtin/commit.c | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/builtin/commit.c b/builtin/commit.c
index 8d1cac062..0a5676b76 100644
--- a/builtin/commit.c
+++ b/builtin/commit.c
@@ -841,9 +841,11 @@ static int prepare_to_commit(const char *index_file, const char *prefix,
"with '%c' will be kept; you may remove them"
" yourself if you want to.\n"
"An empty message aborts the commit.\n"), comment_line_char);
- if (only_include_assumed)
+ if (only_include_assumed) {
+ status_printf_ln(s, GIT_COLOR_NORMAL, "%s", ""); // Add new line for clarity
status_printf_ln(s, GIT_COLOR_NORMAL,
"%s", only_include_assumed);
+ }
/*
* These should never fail because they come from our own
@@ -877,8 +879,7 @@ static int prepare_to_commit(const char *index_file, const char *prefix,
(int)(ci.name_end - ci.name_begin), ci.name_begin,
(int)(ci.mail_end - ci.mail_begin), ci.mail_begin);
- if (ident_shown)
- status_printf_ln(s, GIT_COLOR_NORMAL, "%s", "");
+ status_printf_ln(s, GIT_COLOR_NORMAL, "%s", ""); // Add new line for clarity
saved_color_setting = s->use_color;
s->use_color = 0;
@@ -1209,7 +1210,7 @@ static int parse_and_validate_options(int argc, const char *argv[],
if (argc == 0 && (also || (only && !amend && !allow_empty)))
die(_("No paths with --include/--only does not make sense."));
if (argc > 0 && !also && !only)
- only_include_assumed = _("Explicit paths specified without -i or -o; assuming --only paths...");
+ only_include_assumed = _("Explicit paths (<paths>) specified without -i or -o; assuming --only <paths>");
if (!cleanup_arg || !strcmp(cleanup_arg, "default"))
cleanup_mode = use_editor ? CLEANUP_ALL : CLEANUP_SPACE;
else if (!strcmp(cleanup_arg, "verbatim"))
--
2.11.0