[PATCH v3 0/7] PCRE v2, PCRE v1 JIT, log -P & fixes
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- May 25, 2017, 20:05 UTC
- Message-ID
- <20170525200528.22037-1-avarab@gmail.com>
See <20170523192453.14172-1-avarab@gmail.com> for v2 (https://public-inbox.org/git/20170523192453.14172-1-avarab@gmail.com/).
This on top of "[PATCH v4 00/31] Easy to review grep & pre-PCRE changes".
This hopefully addresses all the comments I had on v2. Comments below:
Ævar Arnfjörð Bjarmason (7): grep: don't redundantly compile throwaway patterns under threading grep: skip pthreads overhead when using one thread log: add -P as a synonym for --perl-regexp
No changes.
grep: add support for the PCRE v1 JIT API
* Simplify logic around canjit variable.
* s/BUG: // for things that aren't internal bugs (but keep it for one that's an actual bug if it happens...)
* Simplify syntax around `#ifdef PCRE_CONFIG_JIT` blocks.
grep: un-break building with PCRE < 8.32
* Reword commit message for less confusion.
* Macro name: s/GIT_PCRE1_CAN_DO_MODERN_JIT/GIT_PCRE1_USE_JIT/g
grep: un-break building with PCRE < 8.20
No changes.
grep: add support for PCRE v2
* Makefile: Clarify comment about what LIBPCREDIR=* does now.
* Makefile: One use of USE_LIBPCRE is now USE_LIBPCRE1. It's logically the same, but less confusing now.
* grep.c: Fix up comment syntax
* grep.c: Same canjit & s/BUG: // bug fixes as noted for PCRE v1.
Documentation/rev-list-options.txt | 1 + Makefile | 36 +++++-- builtin/grep.c | 16 +++- configure.ac | 77 ++++++++++++--- grep.c | 187 ++++++++++++++++++++++++++++++++++++- grep.h | 31 ++++++ revision.c | 2 +- t/t4202-log.sh | 12 +++ t/test-lib.sh | 2 +- 9 files changed, 335 insertions(+), 29 deletions(-)
-- 2.13.0.303.g4ebf302169