Re: [PATCH 09/23] files-backend: move `lock` member to `files_ref_store`
- From
Jeff King <peff@peff.net>
- Date
- May 17, 2017, 13:15 UTC
- Message-ID
- <20170517131459.uznay3pmzgxijunm@sigill.intra.peff.net>
- In-Reply-To
- <9b52c29411fa11ac0d8227d5ae78ba2768485b3f.1495014840.git.mhagger@alum.mit.edu>
On Wed, May 17, 2017 at 02:05:32PM +0200, Michael Haggerty wrote:
Show 11 quoted lines
> @@ -70,6 +61,13 @@ struct files_ref_store {
>
> struct ref_cache *loose;
> struct packed_ref_cache *packed;
> +
> + /*
> + * Iff the packed-refs file associated with this instance is
> + * currently locked for writing, this points at the associated
> + * lock (which is owned by somebody else).
> + */
> + struct lock_file *packlock;I'm glad to see you renamed this from just "lock", though the short "pack" makes me think of packed objects. I don't know if "packed_refs_lock" would be too verbose (I see it's just "packed" above, so maybe "packed_lock").
</bikeshed>
-Peff