Re: [PATCH 22/29] grep: change the internal PCRE macro names to be PCRE1
- From
- Brandon Williams <bmwill@google.com>
- Date
- May 11, 2017, 20:10 UTC
- Message-ID
- <20170511201015.GG83655@google.com>
- In-Reply-To
- <20170511091829.5634-23-avarab@gmail.com>
On 05/11, Ævar Arnfjörð Bjarmason wrote:
Show 19 quoted lines
> Change the internal USE_LIBPCRE define, & build options flag to use a > naming convention ending in PCRE1, without changing the long-standing > USE_LIBPCRE Makefile flag which enables this code. > > This is for preparation for libpcre2 support where having things like > USE_LIBPCRE and USE_LIBPCRE2 in any more places than we absolutely > need to for backwards compatibility with old Makefile arguments would > be confusing. > > In some ways it would be better to change everything that now uses > USE_LIBPCRE to use USE_LIBPCRE1, and to make specifying > USE_LIBPCRE (or --with-pcre) an error. This would impose a one-time > burden on packagers of git to s/USE_LIBPCRE/USE_LIBPCRE1/ in their > build scripts. > > However I'd like to leave the door open to making > USE_LIBPCRE=YesPlease eventually mean USE_LIBPCRE2=YesPlease, > i.e. once PCRE v2 is ubiquitous enough that it makes sense to make it > the default.
I know this isn't what you initially wanted but its probably the safest option. Thanks.
-- Brandon Williams