Re: [PATCH v2 00/21] object_id part 7
- From
Jeff King <peff@peff.net>
- Date
- Mar 28, 2017, 07:31 UTC
- Message-ID
- <20170328073159.k3xemw6auh3iedgs@sigill.intra.peff.net>
- In-Reply-To
- <20170326160143.769630-1-sandals@crustytoothpaste.net>
On Sun, Mar 26, 2017 at 04:01:22PM +0000, brian m. carlson wrote:
Show 5 quoted lines
> This is part 7 in the continuing transition to use struct object_id. > > This series focuses on two main areas: adding two constants for the > maximum hash size we'll be using (which will be suitable for allocating > memory) and converting struct sha1_array to struct oid_array.
Both changes are very welcome. I do think it's probably worth changing the name of sha1-array.[ch], but it doesn't need to happen immediately.
I read through the whole series and didn't find anything objectionable. The pointer-arithmetic fix should perhaps graduate separately.
I suggested an additional cleanup around "linelen" in one patch. In the name of keeping the number of re-rolls sane, I'm OK if we skip that for now (the only reason I mentioned it at all is that you have to justify the caveat in the commit message; with the fix, that justification can go away).
-Peff