git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH] t3600: rename test to describe its functionality

From
Stefan Beller <sbeller@google.com>
Date
Mar 21, 2017, 21:08 UTC
Message-ID
<20170321210802.9675-1-sbeller@google.com>

This was an oversight in 55856a35b2 (rm: absorb a submodules git dir before deletion, 2016-12-27), as the body of the test changed without adapting the test subject.

Signed-off-by: Stefan Beller <sbeller@google.com>
---
 t/t3600-rm.sh | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/t/t3600-rm.sh b/t/t3600-rm.sh
index 5aa6db584c..1f87781e94 100755
--- a/t/t3600-rm.sh
+++ b/t/t3600-rm.sh
@@ -658,7 +658,7 @@ test_expect_success 'rm of a populated nested submodule with nested untracked fi
 	test_cmp expect actual
 '
 
-test_expect_success 'rm of a populated nested submodule with a nested .git directory fails even when forced' '
+test_expect_success 'rm of a populated nested submodule with a nested .git directory absorbs the nested git dir' '
 	git reset --hard &&
 	git submodule update --recursive &&
 	(cd submod/subsubmod &&
-- 
2.12.1.386.gf8442ebc0a.dirty
Next: Jonathan Nieder
Message 1 of 4 in “t3600: rename test to describe its functionality”
  1. t3600: rename test to describe its functionalityStefan Beller, Mar 21, 2017
  2. Jonathan NiederMar 22, 2017
  3. t3600: rename test to describe its functionalityStefan Beller, Mar 22, 2017
  4. Jonathan NiederMar 22, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.