git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 2/5] sha1_file.c: make pack-name helper globally accessible

From
Jeff King <peff@peff.net>
Date
Mar 16, 2017, 17:40 UTC
Message-ID
<20170316174007.gwficwtsqocld4h4@sigill.intra.peff.net>
In-Reply-To
<fefb69e1-325d-5ec6-0954-1445ce8ad9be@ramsayjones.plus.com>
On Thu, Mar 16, 2017 at 05:03:03PM +0000, Ramsay Jones wrote:
Show 23 quoted lines
> > Incidentally, this entire function could be implemented as:
> > 
> >   return git_path_buf(buf, "objects/pack/pack-%s.%s",
> >                       sha1_to_hex(sha1), ext);
> > 
> > as the git_path() functions are smart enough to replace "objects/" with
> > the true object directory when necessary. I don't know if people find
> > that more or less readable. Since it's buried in a helper function, I
> > doubt it matters much either way. The git_path functions do also do some
> > path normalization, which might be of value.
> 
> Hmm, I don't have strong feelings either way.
> 
> However, I note that the only normalization going on (that I can see)
> is to remove .//* from the beginning of the resulting string. I don't
> know why, but I guess it is to cater to people using the various
> GIT_ environment variables doing things like:
> 
>    $ GIT_OBJECT_DIRECTORY=./my-objects git ....
> 
> It has always puzzled me slightly, why the git_path functions do this
> normalization, but (for example) setup_git_env(), git_path_from_env(),
> get_common_dir(), ... don't! ;-)

I think there's some double-slash normalization (though not consistent or thorough). So yeah, I'm not really sure the normalization is of great value. I am surprised that there isn't a call to "convert_slashes()" in there on Windows, as it seems to be sprinkled other places (like prefix_filename()).

<shrug> If nobody's complaining, I'm happy to leave it as-is for now, and if somebody comes up with a case where git_path normalization makes a difference, we can look at switching it.

-Peff
Previous: Ramsay JonesNext: Jeff King
Message 17 of 25 in “minor pack-name cleanups”
  1. 0/6 minor pack-name cleanupsJeff King, Mar 15, 2017
  2. 1/6 index-pack: factor out pack/idx finalizationJeff King, Mar 15, 2017
  3. Ramsay JonesMar 15, 2017
  4. Jeff KingMar 15, 2017
  5. Jeff KingMar 15, 2017
  6. 2/6 move odb_* declarations out of git-compat-util.hJeff King, Mar 15, 2017
  7. 6/6 odb_pack_keep(): stop generating keepfile nameJeff King, Mar 15, 2017
  8. Junio C HamanoMar 16, 2017
  9. 3/6 sha1_file.c: make pack-name helper globally accessibleJeff King, Mar 15, 2017
  10. 4/6 index-pack: drop fixed-size buffer for pack filenamesJeff King, Mar 15, 2017
  11. 5/6 fast-import: replace fixed buffer with odb_pack_nameJeff King, Mar 15, 2017
  12. 0/5 minor pack-name cleanupsJeff King, Mar 16, 2017
  13. 1/5 move odb_* declarations out of git-compat-util.hJeff King, Mar 16, 2017
  14. 2/5 sha1_file.c: make pack-name helper globally accessibleJeff King, Mar 16, 2017
  15. Jeff KingMar 16, 2017
  16. Ramsay JonesMar 16, 2017
  17. Jeff KingMar 16, 2017
  18. 3/5 odb_pack_keep(): stop generating keepfile nameJeff King, Mar 16, 2017
  19. 4/5 replace snprintf with odb_pack_name()Jeff King, Mar 16, 2017
  20. Ramsay JonesMar 16, 2017
  21. Junio C HamanoMar 16, 2017
  22. Jeff KingMar 16, 2017
  23. Junio C HamanoMar 16, 2017
  24. 5/5 index-pack: make pointer-alias fallbacks saferJeff King, Mar 16, 2017
  25. Ramsay JonesMar 16, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.