git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 1/6] index-pack: factor out pack/idx finalization

From
Jeff King <peff@peff.net>
Date
Mar 15, 2017, 21:27 UTC
Message-ID
<20170315212733.73cw22dm36oc5im4@sigill.intra.peff.net>
In-Reply-To
<20170315212617.6x57bvltinuozv4q@sigill.intra.peff.net>

The procedure for moving the ".pack" and the ".idx" files into place is the same. Rather than repeat the code, let's factor it into a helper function.

This has the added benefit of clarifying the lifetime of "final_pack_name". In the original code it is sometimes redirected to our reusable "name" buffer; after we reuse that buffer, the contents are nonsense (but nobody looks at it, so this is not a bug, just a maintenance issue). In the new code, the pointer modification is contained in the helper function.

Signed-off-by: Jeff King <peff@peff.net>
---
 builtin/index-pack.c | 40 +++++++++++++++++++---------------------
 1 file changed, 19 insertions(+), 21 deletions(-)
diff --git a/builtin/index-pack.c b/builtin/index-pack.c
index f4b87c6c9..187c0550c 100644
--- a/builtin/index-pack.c
+++ b/builtin/index-pack.c
@@ -1380,6 +1380,23 @@ static void fix_unresolved_deltas(struct sha1file *f)
 	free(sorted_by_pos);
 }
 
+static void finalize_file(const char *final_name, const char *curr_name,
+			  unsigned char *sha1, const char *ext)
+{
+	if (final_name != curr_name) {
+		char name[PATH_MAX];
+		if (!final_name) {
+			snprintf(name, sizeof(name), "%s/pack/pack-%s.%s",
+				 get_object_directory(), sha1_to_hex(sha1),
+				 ext);
+			final_name = name;
+		}
+		if (finalize_object_file(curr_name, final_name))
+			die(_("cannot store %s file"), ext);
+	} else if (from_stdin)
+		chmod(final_name, 0444);
+}
+
 static void final(const char *final_pack_name, const char *curr_pack_name,
 		  const char *final_index_name, const char *curr_index_name,
 		  const char *keep_name, const char *keep_msg,
@@ -1422,27 +1439,8 @@ static void final(const char *final_pack_name, const char *curr_pack_name,
 		}
 	}
 
-	if (final_pack_name != curr_pack_name) {
-		if (!final_pack_name) {
-			snprintf(name, sizeof(name), "%s/pack/pack-%s.pack",
-				 get_object_directory(), sha1_to_hex(sha1));
-			final_pack_name = name;
-		}
-		if (finalize_object_file(curr_pack_name, final_pack_name))
-			die(_("cannot store pack file"));
-	} else if (from_stdin)
-		chmod(final_pack_name, 0444);
-
-	if (final_index_name != curr_index_name) {
-		if (!final_index_name) {
-			snprintf(name, sizeof(name), "%s/pack/pack-%s.idx",
-				 get_object_directory(), sha1_to_hex(sha1));
-			final_index_name = name;
-		}
-		if (finalize_object_file(curr_index_name, final_index_name))
-			die(_("cannot store index file"));
-	} else
-		chmod(final_index_name, 0444);
+	finalize_file(final_pack_name, curr_pack_name, sha1, "pack");
+	finalize_file(final_index_name, curr_index_name, sha1, "idx");
 
 	if (!from_stdin) {
 		printf("%s\n", sha1_to_hex(sha1));
-- 
2.12.0.613.g6e7c52a0d
Previous: Jeff KingNext: Ramsay Jones
Message 2 of 25 in “minor pack-name cleanups”
  1. 0/6 minor pack-name cleanupsJeff King, Mar 15, 2017
  2. 1/6 index-pack: factor out pack/idx finalizationJeff King, Mar 15, 2017
  3. Ramsay JonesMar 15, 2017
  4. Jeff KingMar 15, 2017
  5. Jeff KingMar 15, 2017
  6. 2/6 move odb_* declarations out of git-compat-util.hJeff King, Mar 15, 2017
  7. 6/6 odb_pack_keep(): stop generating keepfile nameJeff King, Mar 15, 2017
  8. Junio C HamanoMar 16, 2017
  9. 3/6 sha1_file.c: make pack-name helper globally accessibleJeff King, Mar 15, 2017
  10. 4/6 index-pack: drop fixed-size buffer for pack filenamesJeff King, Mar 15, 2017
  11. 5/6 fast-import: replace fixed buffer with odb_pack_nameJeff King, Mar 15, 2017
  12. 0/5 minor pack-name cleanupsJeff King, Mar 16, 2017
  13. 1/5 move odb_* declarations out of git-compat-util.hJeff King, Mar 16, 2017
  14. 2/5 sha1_file.c: make pack-name helper globally accessibleJeff King, Mar 16, 2017
  15. Jeff KingMar 16, 2017
  16. Ramsay JonesMar 16, 2017
  17. Jeff KingMar 16, 2017
  18. 3/5 odb_pack_keep(): stop generating keepfile nameJeff King, Mar 16, 2017
  19. 4/5 replace snprintf with odb_pack_name()Jeff King, Mar 16, 2017
  20. Ramsay JonesMar 16, 2017
  21. Junio C HamanoMar 16, 2017
  22. Jeff KingMar 16, 2017
  23. Junio C HamanoMar 16, 2017
  24. 5/5 index-pack: make pointer-alias fallbacks saferJeff King, Mar 16, 2017
  25. Ramsay JonesMar 16, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.